Support » Fixing WordPress » Permalink issues with

  • Hello, I have made a blog and I’m fairly new to wordpress. It’s actually my first site in general. I have had help from my buddy, who is pretty savvy, but both of us are puzzled with a permalinks issues. We use Apache/2.2.20 (Ubuntu) for the server. I had originally set up the WordPress blog on an amazon ec2 instance, with the blog being located in a subdirectory of the server. Recently, I bought a domain called http://www.alldenversports.com.

    Everything went well, the site was functional. However, in order to get better viewership on search engines, I was told to change the permalinks to something like post name. So I did. When I change it from default to post name, I get the 404 the requested URL not found on site along with the title of my post. When I switch it back to default, it works, but all I get is something like my domain name/?=p397

    I’ve looked around on fixes, but I haven’t been able to find the cause. We’ve setup a DocumentRoot. Our .httpd.conf is actually apache2.conf, but it seems to be configured properly. We have two .htaccess, one in the /var/www directory and one in /var/www/sportsBlog/wordpress/. In the wordpress directory, we added some gibberish to the .htaccess to ensure it is reading and it is. It’s weird because when I change the structure of the permalinks in settings, WordPress tells me update my .htaccess because it isn’t writeable. This is what I have in the .htaccess

    Options +FollowSymLinks +MultiViews
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    I’ve also have deactivated every plugin and I tried changing themes, but alas I get the same 404 issues. In case it’s useful, I’m using the “Asteroid” theme. I was hopeful I was going to be able to figure it out myself, but I am quite lost what to do next. My buddy isn’t sure exactly what to do either. If anyone has any has encountered these issues or have any possible solutions, it’d be greatly appreciated.

    Thank you very much

Viewing 6 replies - 1 through 6 (of 6 total)
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Permalink issues with’ is closed to new replies.