WordPress.org

Ready to get started?Download WordPress

Forums

Permalink issues - 'Oops this link appears to be broken' (4 posts)

  1. canchuckwood
    Member
    Posted 4 years ago #

    Hi folks

    I'm having trouble with Google's 'Oops this link appears to be broken' error message. I'm presuming it has something to do with permalinks and htaccess.

    The website is cheapcontacts.co.nz (username: admin / password: eyesee123). When the permalinks are the default structure, I can access the pages eg. FAQ, contact, but not the WP ECommerce groups and products. When I try pretty permalinks, I can't go anywhere beyond the home page.

    I discovered WordPress hadn't generated a .htaccess file on installation, so I created one and added the following:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    but that hasn't helped.

    Any ideas? Help is much appreciated.

    Thanks, Charlette

  2. jceresini
    Member
    Posted 4 years ago #

    You may need to verify that your web server both supports rewrite rules, and it setup to allow them for your virtualhost and directory. Your host should be able to help determine this. One quick and dirty way to find out is to put gibberish into the .htaccess file, just random characters like "asdf" at the top of it. If the web server supports it, then it will fail to parse the file and display an error when you try to visit the website.

  3. menzraf
    Member
    Posted 4 years ago #

    lately I have been getting this message

    'Oops! It's not here...
    Sorry to be the bearer of bad news, but this page doesn't seem to exist. Kindly use the search functionality in the header to find what you're looking for.'

    This happens even when am trying to login into admin, or post, edit post, etc but if i try i couple of times am able to get through. Its been happening frequently and i have not done anything extra ordinarily but the normal daily posting....

    Please help!
    Menzraf

  4. ignaciosagone
    Member
    Posted 3 years ago #

    i just created the . htaccess file with the script you did,

    uploaded it and everything worked

    thanks man!

Topic Closed

This topic has been closed to new replies.

About this Topic