Support » Fixing WordPress » Permalink Issues Not Reverting Back to Default – 500 Internal Server Error

  • Here’s a strange issue, so here’s hoping someone can help:

    I recently installed Yoast SEO on my WP site. The plug-in noticed that I had the Default (?p=123) permalinks and recommended me switch to %postname% for better SEO. Forgetting that I had to use the “default” permalinks with my current theme, I switched over and hit “Save Changes” only to find a 500 Internal Server Error message. I immediately called my hosting site to see if they could revert my site back to yesterday’s save (which they would do for an egregious wade of cash -> $180) but they told me that I can revert files back for myself. I tried this option, but to no success. I went back a few days – still no success. I had kept a whole backup file on my computer from last year, to which I uploaded via Filezilla.

    I know about the .htaccess file, the trick to rename/delete the file, empty cache and browser history, etc. I replaced the .htaccess file several times but when I go back to WP–>Settings–>Permalinks and click back to “Default” and hit save changes, I get an Internal Server Error message again and have to re-upload the .htaccess file again in order to get back to the Dashboard. I’m not sure what do to and how to fix it.

    I also made sure to delete the Plug-in for the meanwhile in case the plug-in is doing something funky with the .htaccessfile.

    Here is what my .htaccess file looks like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Are there any hidden files that are being written to… and/or can I rewrite the .htaccess file manually so as to switch back to “Default” permalinks? Is there something I am missing here?

    Here is a link to the website:

  • The topic ‘Permalink Issues Not Reverting Back to Default – 500 Internal Server Error’ is closed to new replies.