Support » Fixing WordPress » Permalink issues in 2.7.1: Only default and Numeric settings work

  • Server is RHEL5, running PHP 5.1.6

    I need to set up a custom permalink structure (specifically: /%year%/%monthnum%%day%-%postname%/) but only the default setting (/?p=%post_id%) and numeric (/archives/%post_id%) work. All other structure (Day and Name, Month and Name, or my custom) end up going to the post not found message.

    The .htaccess file is in place and is working correctly. If I try to navigate directly to, wordpress redirects to If I insert phpinfo();exit(); into the index.php page that requests should be redirecting to, and then navigate to i get the phpinfo as I should.

    Any ideas? Something easy I’m overlooking? I dont mind digging into canonical.php but would rather not if i dont have to.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Where is your .htaccess file located?

    Where is your .htaccess file located?

    root of the wordpress installation.

    anyone have any guesses/ideas?

    Ahah!! It’s not just me!!! Thank you, thank you, thank you – I was starting to feel really stupid, certain this had to be “inexperienced user error.” I’m getting the same thing!

    No suggestions or guesses – but if you find an answer, I’d like to see it, too!

    @ HollyJahangiri
    it’s not the same problem at all as in your topic

    @ gilzow
    the structure you have posted won’t work
    you need it like

    @samboll – except that it still doesnt work. Neither my custom permalink structure, the permalink structure you posted, nor any of the default permalink options (Day and Name or Month and Name) work. So even if I set it up the way you suggested (/%year%/%monthnum%/%day%/%postname%) I still get the 404 post not found message. Only the default and numeric permalink structures work correctly.

    See, I think it IS the same problem, Samboll.

    Your suggested “fix” is what I’d already tried. I’ve implemented it again so that you can see what it IS doing, but it’s not right.

    Unlike glizow, I don’t think anything but the Default structure works for me. <– Looks fine. But click the titles – the permalinks look lovely, now, but they don’t WORK:

    Ryan S


    I am not sure what wrong you are doing, but the correct permalink will be /%year%/%monthnum%/%day%/%postname%

    Also, check if you have any unnecessary plugin installed.

    @ryan_accuwebhosting no offense, but your “help” isn’t very helpful. Telling me that I’m doing something wrong, and then suggesting that I try something that I have already stated twice that I *HAVE* tried is a bit frustrating.

    Now your suggestion on plugins might have some validity. @hollyjahangiri, do you mind listing the plugins you have installed? Let’s see if we are both using one or more and then look into whether or not those plugins might be causing an issue.

    Dr. Register
    More Fields
    WordPress Admin and Login Themer
    WP Hide Dashboard

    ok, so i went back and uninstalled all of the plugins I was using, changed the permalink settings to default, saved, changed them back to Day and name, saved again and tried to go to my test post ( <– you wont be able to get there; only posting so you can see URL structure is correct) and received the 404 error message. I also went in and added a category base and a tag base as another forum thread mentioned that adding those had helped another user’s permalinks start working correctly. I still get the 404 error.

    So then I went and redownloaded the wordpress core and installed it into another account that I have so that it would be perfectly clean and no possibility of something interfering. After logging in I changed the permalink setting to Day and Name, saved, verified the .htaccess file was created, created a test post, published and attempted to go to the generated pretty URL, i get a 404 error. Only default and numeric permalink settings work.

    I have also verified with our SysAdmin that the FollowSymLinks options is enabled for my account.

    For me, it turned out to be a simple permissions problem. (Compounded by the fact that I’d put .htaccess under wp-content to start with.) I ended up opening my entire installation with 777, getting WordPress to finally generate the .htaccess file (that put it in the right place, at least), and everything worked – until Apache shut me out. 403 error. I thought my hosting support folks did it, just to stop me from mucking around while they tried to troubleshoot. But for some reason, some things won’t work with the documented permissions – they won’t work unless set to 777. Not 666. Dunno why, but for most things, it may be easier to edit offline – not use the built-in editor. Then again, without the built-in editor, I might never have figured out where .htaccess really ought to be. 🙂

    Plug-ins activated (this has changed, most likely, since the problem was fixed – but I think it’s irrelevant):

    Akismet 2.2.4
    All in One SEO Pack 1.5.1
    commentluv 2.6.5
    Feed reading Blogroll 1.2.1
    Import Blogroll With Categories 1.0
    OpenID 3.2.2

    Ryan S



    Yes, I understand that you have already stated the permalink structure and it was correct. However, I provided you the structure just to make sure if you are using it correctly.

    Also, try to check the permissions again… One more thing.. make sure the the reqrite rule is present in your .htaccess file (I know it sounds stupid, but sometimes this happens).



    If nothing works then maybe it is the problem that I faced.
    – Upgraded to WordPress v 2.8.1 – no problems before that
    – Tried to change permalinks and got all these unsolvable htaccess errors
    – Even deleted the WP installation and everything and reinstalled but same problem
    – Got a brainwave – Thank God!
    – Went to WP Settings -> General, changed the default settings for BOTH URL areas to point to simply
    – Permalinks working again !
    – Actually I am using the ‘add domain’ feature to host multiple domains in a single account in bluehost. So the default in WP settings points to which dosen’t work.

    – Trust that helps someone.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Permalink issues in 2.7.1: Only default and Numeric settings work’ is closed to new replies.