WordPress.org

Forums

permalink issue on IIS 7 (2 posts)

  1. coding4fun
    Member
    Posted 3 years ago #

    Hello,
    I am having trouble getting my site to display permalinks. The default permalink works fine. But the post name permalink, which I need to have for my business webpage, does not. I get 403 - Forbidden: Access is denied.

    I have installed IIS7 on Windows Server 2008. I have enabled php and fastcgi. I have added this rewrite rule, as instructed, into web.config. There is no change.

    <rewrite>
    <rules>
    <rule name="Main Rule" stopProcessing="true">
    <match url=".*" />
    <conditions logicalGrouping="MatchAll">
    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
    </conditions>
    <action type="Rewrite" url="index.php" />
    </rule>
    </rules>
    </rewrite>

    Here's the entire code for web.config, in the wwwroot folder. The site itself is in a directory called "wordpress":
    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <defaultDocument enabled="true">
    <files>
    <clear />
    <add value="index.php" />
    <add value="Default.htm" />
    <add value="Default.asp" />
    <add value="index.htm" />
    <add value="index.html" />
    <add value="iisstart.htm" />
    <add value="default.aspx" />

    </files>
    </defaultDocument>
    <rewrite>
    <rules>
    <rule name="Main Rule" stopProcessing="true">
    <match url=".*" />
    <conditions logicalGrouping="MatchAll">
    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
    </conditions>
    <action type="Rewrite" url="index.php/{R:0}" />
    </rule>
    </rules>
    </rewrite>
    <handlers>
    <remove name="PHP53_via_FastCGI" />
    <add name="PHP53_via_FastCGI" path="*.php" verb="GET,HEAD,POST" modules="FastCgiModule" scriptProcessor="C:\Program Files (x86)\PHP\v5.3\php-cgi.exe" resourceType="Either" requireAccess="Script" />
    </handlers>
    </system.webServer>
    </configuration>

  2. coding4fun
    Member
    Posted 3 years ago #

    So, I converted all my permalinks to custom structure with
    /index.php/%postname%/

    So every page is hard coded to
    http://123.ipaddress.345.0/wordpress/index.php/hello-world/

    But that is the only way to get a permalink with words in it. Of course, I am concerned about the site going live like this.

    I am aware from these boards that wordpress custom permalinks and IIS7 Windows server do not get along well. But this situation is not up to me, but the client. I would sure appreciate some help!

    Thank you

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.