Support » Plugin: Beautiful taxonomy filters » Permalink issue on applying filter

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jonathandejong

    (@jonathandejong)

    Hi @nakush

    In the open source community you really can’t just expect a solution provided to you for everything. That’s just not how this thing works 🙂
    Keep that in mind when phrasing how you want to get free help.

    $new_url = trailingslashit( get_post_type_archive_link( $current_post_type ) );

    This is the code inside BTF that generates the base URL for the redirected request upon filtering. If you end up on .com instead of .com/dev/ then you likely have missed changing some value in your install. If you were to try to find the solution yourself and followed the trail you’d see that the get_post_type_archive_link() function uses get_home_url() which fetches its home url from the home key in the wp_options table like this get_option( 'home' );
    So you should look at your set values for this to make sure they are correct.

    Best of luck with your project,
    Jonathan

    Thread Starter nakush

    (@nakush)

    ok, Thanks. Can we show the output on the same template page? If yes then how? I am using this shortcode ” <?php do_action(‘show_beautiful_filters’); ?> ” in my template.

    And if you have any tutorial of this plugin or documentation. Please share it with me.

    Plugin Author Jonathandejong

    (@jonathandejong)

    Hi @nakush

    Not sure what you mean. The rendered results is always on the archive page because that’s how WordPress has to render it. BTF does not do its own filter engine but uses WordPress own and places rewrite rules on it to make it pretty.
    There’s a bunch of topics on this already as well as info in the FAQ.

    Right now there’s no other documentation but the readme on wordpress.org + a lot of instructions and clarifications on the settings pages help section.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.