WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Permalink issue Error 404

[Resolved] Permalink issue Error 404

  • Hello! I am sorry for a somewhat redundant post, I found similar issues in other posts, but for the most part couldnt understand the fixes offered as I am a WP/server seedling.
    I just created 2 new pages, and they both show error 404, while all others work(site is set up to /%postname%/ permalink). if I switch back to default permalinks, all pages show fine, but moving back to /%postname%/ makes the 2 new pages error 404 again. I read about WP needing write access to change the .htaccess file among other things in WP codex but being such a newb, this might as well be greek. my htaccess file looks like this, which seems right –

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    any help is much appreciated, the more newb directed the better. Thanks! http://www.abishandmade.com

Viewing 1 replies (of 1 total)
  • Fixed it! It was a plugin issue. Check box under woocommerce>settings>pages “Prepend product permalinks with shop base page (shop) Note: The shop page has children – child pages will not work if you enable this option. ” needed to be unchecked.

    Thanks to anyone who spent time looking in to it for me.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Permalink issue Error 404’ is closed to new replies.
Skip to toolbar