Support » Plugin: Polylang » Permalink issue causes “nothing found” pages

  • Resolved felastec



    After a long chat with the WordPress CMS team, we come to the conclusion that Polylang is causing problems with our links. About once per week, some kind of update from Polylang is causing all of our pages in German except “Start”, to shows as “NOTHING FOUND“. With a click on save changes in the WordPress Permalink database , the webpage is however working normal again.

    Our settings:

    <strong>Static Webpage</strong>
    <strong>Settings Polylang Permalinks:</strong> 
    <em>-The language is set from the directory name in pretty permalinks</em> 
    <em>-Remove /language/ in pretty permalinks</em>
    <em>-Hide URL language information for default language</em>
    <strong>Settings Worpress Permalinks: </strong>
    <em>- Post name</em>
    Other active Plugins:
    • This topic was modified 2 years, 9 months ago by felastec.
    • This topic was modified 2 years, 9 months ago by Jan Dembowski.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi,

    I had the same problem some time ago. I found out that I had “Remove the categories prefix of Category URLs” from the Yoast SEO plugin activated. In some cases – after I made one or more changes in the category names/structure/slug – the “Nothing Found” error was shown.

    After I had deactivated “Remove the categories prefix” under SEO -> Search Appearance -> Taxonomies -> Category URLs -> Remove the categories prefix, the error was gone. As I still wanted the “category” slug to be removed, I used another plugin, which works perfect with the Polylang plugin:

    Best regards,

    Thread Starter felastec


    Hi Benjamin

    Thanks a lot for your answer.
    I will get back in a week to confirm this solution for other people!

    Kind Regards

    Thread Starter felastec


    Hi Benjamin,

    Thanks again for your answer, unfortunately it did not help though.
    Today I check my page again and it comes up as


    This is how the page looks like.

    Thankful for all answers,

    • This reply was modified 2 years, 8 months ago by felastec.
    • This reply was modified 2 years, 8 months ago by felastec.
    • This reply was modified 2 years, 8 months ago by felastec.

    I got the same issue with my site.
    The first occurrence was after Polylang’s 2.3.9 upgrade. I then go to “URL modifications” settings of Polylang and use the “Save Changes” button without changing anything.
    This will solve the issue, but it seems temporarily.
    I have had this happen again this weekend, which means it is not occurring with each Polylang update, as I had initially thought.
    I will try to monitor the issue and make a daily sanity check of my page’s status. If I find some recurring pattern, I will let you know.


    I also have the same issue with my site

    I’ve created a staging site and deactivated all plugins and can see that Polylang is the reason for the not found error, and refreshing the permalinks resolves it but then it happens again randomly.

    I have reached out to Polylang to see if upgrading to Pro will fix this issue. Still waiting on a reply. Does anyone know if this will resolve the problem?

    Thread Starter felastec


    Hi @tcmos
    Thanks reaching out to Polylang you as well.
    I am looking forward to hear about their reply!

    Cheers/ Carl

    Thread Starter felastec


    Today it happened first time again since my last reported crash 2 weeks & 5 days ago.
    All I have in my “Activity” logbook is that Yoast SEO autoupdated.

    Will try to turn on autoupdates for this plugin as well to see further changes.

    Thread Starter felastec


    Will mark this as solved, as they problem did not occur since my last message.
    I have not made any changes and I am not sure why it stopped.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Permalink issue causes “nothing found” pages’ is closed to new replies.