Support » Localhost Installs » Permalink Issue

Permalink Issue

  • Hi all,
    I know this post might be similar to the ones that have been posted before but I have been looking around to see if anyone had the same issue as myself with no luck.
    I’ve been having problems with an error code “404 Not Found” followed by a message “The requested URL /xva0wordpress/index.php was not found on this server.
    “Its seems that when I change my permalinks to anything else but default, it will come up with the error.I dont really want the permalinks to be on default as this is part of my examination to make the site SEO friendly. All this work is not online at the moment as im working on my localhost using “MAMP”.If someone could tell me how I could sort this out that would be great.

    Thanks in advance

Viewing 8 replies - 1 through 8 (of 8 total)
  • Have you added the given code into your .htaccess file

    Not sure if this applies when using MAMP but worth a try?

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Thanks for the quick response.

    I have tried adding a .htaccess folder on the wordpress directory with the same type of code you suggested but it still comes up with the same error.



    You mean a .htaccess FILE right? Not folder…

    You may need to check your MAMP settings and ensure URL re-writing is enabled (normally mod_rewrite has to be enabled on servers).

    mod_rewrite enabled/disabled was my next suggestion! Phil beat me there

    Thanks guys, Im trying to find the settings to enable mod_rewrite but cant seem to find it anywhere, MAMP sucks, I usually use WAMP and I haven’t had this problem before.Dont know if you guys can direct me to where I can enable mod_rewrite?.thanks…

    Thanks Damian,

    That link didn’t really help much, I had a look at it before you posted it and it doesn’t tell you how to find it, even the other person can’t find the mod_rewrite in mamp.

    Hi guys my mod_rewrite is enabled, and it does create a .htaccess every time i change my permalinks.but it still does the same thing where if i use the default settings it works fine but as soon as i use a custom structure is comes up with the same error again.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Permalink Issue’ is closed to new replies.