Support » Fixing WordPress » Permalink is not working,

  • Resolved sam75m

    (@sam75m)


    I’ve set Permalink to Numeric, and my .htaccess changed to:

    # BEGIN WordPress
    # The directives (lines) between “BEGIN WordPress” and “END WordPress” are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>

    # END WordPress
    =========
    I’ve installed wp in domain.com/blog/ but permalik is not working ang gives me “Not Found” error.
    in apache2 configuration I have AllowOverride All, and also I tested .htaccess and it worked fine (I changed it to “deny from all” and my site was not accessible, just want to make sure apache can read it), seems something in wordpress has a problem, is there anything I should set in wp config file?

    • This topic was modified 1 month ago by sam75m.
    • This topic was modified 1 month ago by sam75m.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator t-p

    (@t-p)

    Try resetting your custom permalinks back to the default setting and renaming your WordPress .htaccess file.

    If that works, then try reading Using_Permalinks before setting a custom permalink structure again.

    If clearing your Permalinks does not alleviate the issue, this could be attributed to anything from a web server configuration to a bad WordPress install.

    sam75m

    (@sam75m)

    Thanks for your reply.
    I reset custom permalinks and faced same error,
    I even download and install wp again, still have same problem, I googled and tried lots of troubleshooting but couldn’t find out what’s wrong.
    Facts are:
    1- I installed wp on mydomain.com/blog/ folder
    2- In apache config I have AllowOverride All and I tested .htaccess in blog directory and other directories and seems apache can executing it,
    3- When I set pemalink, it’s making .htaccess
    4- WP will change the links to something pretty like: http://mydomain.com/blog/archives/22
    5- When I click on it I face to Not found page: The requested URL was not found on this server.
    6- It can not be bad WP installation, cause I downloaded the latest one from WP website again,

    Moderator t-p

    (@t-p)

    I reset custom permalinks and faced same error

    Default setting is NOT custom permalinks.

    Default setting is “PLAIN” setting. Does the “PLAIN” setting work?

    sam75m

    (@sam75m)

    Plain is working, that’s frustrating, I gave up and started installing nginx in my VPS, I’ll install WP on nginx cause I know it better than apache,

    Moderator t-p

    (@t-p)

    Plain is working,

    If that works, then try reading Using_Permalinks before setting a custom permalink structure again.

    sam75m

    (@sam75m)

    I spent 6 hours on it, and no result, instead I installed WordPress on LEMP stack (linux, nginx, mysql and php) in less than 10 minutes, now everything works well! by nginx you just need to add couple lines in nginx config file to activate permalink:
    location /blog/ {
    try_files $uri $uri/ /blog/index.php$is_args$args;
    }

    I don’t waste my time on apache anymore 😉 thanks for your time and nice replies.

    • This reply was modified 1 month ago by sam75m.
    Moderator t-p

    (@t-p)

    You are welcome 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.