Support » Fixing WordPress » Permalink index.php links causing internal server error

  • Hi,

    Getting a strange internal server message sporadically when clicking on internal permalinks within pages. I’ve searched the web and these forums, but can’t seem to find anyone else who’s experienced this same issue. If you have, please chime in…

    I’m developing a client site on a Network Solutions hosting account (Unix). Installed WordPress 2.8.2, and customizing an existing theme. Everything works great except now that we’ve tried to add in some internal permalinks within pages & posts.

    For example, we might have text on a page with an underlying link that looks like this in the html tab:

    About Us

    We’ve used this style of permalink on other client sites running WordPress 2.8.2 without an issue, but on this site we get a funky internal server error:

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    HTTP/1.1 200 OK Date: Thu, 20 Aug 2009 22:27:24 GMT Server: Apache/2.2.8 (Unix) FrontPage/ X-Powered-By: PHP/5.2.6 X-Pingback: Expires: Wed, 11 Jan 1984 05:00:00 GMT Cache-Control: no-cache, must-revalidate, max-age=0 Pragma: no-cache Last-Modified: Thu, 20 Aug 2009 22:27:25 GMT Keep-Alive: timeout=5, max=97 Connection: Keep-Alive Transfer-Encoding: chunked Content-Type: text/html; charset=UTF-8 2e49

    What’s even stranger is that on same pages it appears at the top of the page (before the actual page layout begins) and other times it will flash on a blank screen and then redirect to the normal looking page. In all instances, the permalink actually does redirect to the proper page – it’s just the weird error message won’t go away.

    I’ve tried deleting and recreating the .htaccess file, but it had no effect. Here’s what the current .hatccess file in the root folder of the WP install contains:
    Options -Indexes

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress
    Any ideas, suggestions, advice would be sooo much appreciated. Has anyone else had a similar issue and found a good fix? I’ve been working on this for hours with no luck so far!

    I don’t really want to post the client’s development site URL, but if there’s other info I can provide, please let me know.


Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi


    Forum Moderator

    Have you tried deactivating all plugins? Anything funky going on in the theme?

    Thanks for your response. I originally thought it could be the theme, too, but I switched to the classic theme that comes with WordPress and the same error occurred, so don’t think that’s the cause.

    I did deactive ALL plugins (they’re currenlty completely disabled, and I’ve tried reactivating one at a time. The problem appears most of the time, but occasionally it doesn’t seem to happen. Then it reappears. There doesn’t appear to be a rhyme and a reason as to which plugin combo does the trick, and as I said, deactivating them all hasn’t fixed it either.

    The external site links work fine, and those generated directly by WordPress template tags (e.g, wp_list_pages) in the menu bar also work fine. The only ones that are creating the error are when we use a relative permalink within the main page content. I’ve used this Permalink style without problems for other WP 2.8.2 client sites, though none have been on Network Solutions hosting accounts. We also installed WordPress on the site per WordPress’s installation instructions, not using any hosting co. scripts.

    I’ve even tried re-uploading all the WP files (except for wp-config) in case a file or two didn’t upload properly the first time, but still no dice.

    Anyone know which file the permalink code calls are in?? I could post that here if it would help. Maybe there’s an issue with the function call – it’s the only thing I can really think of besides it being an issue with Network Solutions hosting (but that seems unlikely).

    Oops, I just realized my permalink example in the initial post got converted into a link. Here’s the what the a href currently points to if you look at the HTML tab of the page:




    Forum Moderator

    Site url?

    URL where an internal permalink exists:

    If you click on any of the three links within the main body text, the error typically appears. As I mentioned, occasionally it doesn’t – probably about 90% of the time.

    Thanks for any help you can provide!



    Forum Moderator

    Those internal links are incorrect (eg. instead of Are you using relative or absolute urls?

    Thanks, you are terrific! I could swear I tried the absolute links already and still had the same error, but now it’s working like a charm.

    FYI, we were using relative links (no / at the beginning), and we’ve never had an issue doing that. Not sure if maybe this hosting account is set up differently and requires the / on all internal permalinks. Anyhow, it’s fixed! Thank you very, very, very much!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Permalink index.php links causing internal server error’ is closed to new replies.