WordPress.org

Support

Support » Alpha/Beta » Permalink / htaccess RC3

Permalink / htaccess RC3

  • Hello everybody. I have upgraded to RC3-2.0 from 1.5.2. Before upgrade I made backups from .htaccess and the database. The problem is the following: When updating the permalink structure Wp remove all the rewrite rules I had before in 1.5.2. and leaves almost a blank file :

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>
    # END WordPress

    So all my rewrite rules as I had them in 1.5.2. are dissapeared and I cannot acces all my pages and sub-pages because of redirection to the index-page.
    Putting the old htaccess file back works but this isn’t the solution. I used the following permalinkstructure :
    archives/%year%/%monthnum%/%day%/%postname%/.
    Is this a RC3 problem / Or a bug? Or will it be solved in the difinite version
    Anybody?
    Greetings Mazalien

Viewing 15 replies - 1 through 15 (of 27 total)
  • Moderator James Huff

    @macmanx

    Can you set your permalink structure again in Options/Permalinks?

    Macmanx, I have tried that for dozens of times and every time the same problem. I have also set up an another wp-installation of rc3 in a different database, a complete new installation with some dummy-posts and categories, and there is the problem the same. When putting 1.5.2. back in the “dummy” database then the permalinks works just fine.

    Moderator James Huff

    @macmanx

    Do you use a backslash before “archives” in your permalink structure? The structure needs to start with a backslash:

    /archives/%year%/%monthnum%/%day%/%postname%/

    If that still doesn’t work, try the recommended permalink structure:

    /%year%/%monthnum%/%day%/%postname%/

    Yes I have used the backslash, and also tried every other possible combination. The only thing that change is the size of the .htaccess file with a few bytes every time (from 204 bytes to 208 bytes) and some empty lines are added under the # end wordpress-statement. I have also chmod .htaccess to 777, so it is writable.

    Moderator James Huff

    @macmanx

    What are your server details? Preferably your server’s operating system and Apache, PHP, and MySQL version numbers.

    PHP: PHP4u Version 3.0
    Based on PHP-5.0.2
    MySQL 4.0.18
    Server statistics :

    Initiating SYN Stealth Scan against customers.webc.lyceu.net (212.78.206.150) [1668 ports] at 21:05
    Discovered open port 80/tcp on 212.78.206.150
    The SYN Stealth Scan took 29.40s to scan 1668 total ports.
    Warning: OS detection will be MUCH less reliable because we did not find at least 1 open and 1 closed TCP port
    For OSScan assuming port 80 is open, 32587 is closed, and neither are firewalled
    Host customers.webc.lyceu.net (212.78.206.150) appears to be up … good.
    Interesting ports on customers.webc.lyceu.net (212.78.206.150):
    (The 1667 ports scanned but not shown below are in state: filtered)
    PORT STATE SERVICE
    80/tcp open http
    Device type: general purpose
    Running: Linux 2.4.X
    OS details: Linux 2.4.16 – 2.4.18, Linux 2.4.18 – 2.4.21 (x86)
    OS Fingerprint:
    TSeq(Class=RI%gcd=1%SI=1CB3A5%IPID=Z%TS=100HZ)
    T1(Resp=Y%DF=Y%W=16A0%ACK=S++%Flags=AS%Ops=MNNTNW)
    T2(Resp=Y%DF=Y%W=0%ACK=S%Flags=AR%Ops=)
    T3(Resp=Y%DF=Y%W=16A0%ACK=S++%Flags=AS%Ops=MNNTNW)
    T4(Resp=Y%DF=Y%W=0%ACK=O%Flags=R%Ops=)
    T5(Resp=N)
    T6(Resp=Y%DF=Y%W=0%ACK=O%Flags=R%Ops=)
    T7(Resp=N)
    PU(Resp=N)

    Uptime 47.908 days (since Thu Oct 20 23:19:05 2005)
    TCP Sequence Prediction: Class=random positive increments
    Difficulty=1880997 (Good luck!)
    TCP ISN Seq. Numbers: 102EAC5C 101037FC 1002E86F FEB7AAC 10398C09 108B3910
    IPID Sequence Generation: All zeros

    Nmap finished: 1 IP address (1 host up) scanned in 32.039 seconds
    Raw packets sent: 3359 (135KB) | Rcvd: 18 (940B)

    The rewrite rules that redirect to the index are the default for 2.0. They should work. To help debug this problem, install and activate the Dump Environment plugin. Visit a page that is not working properly and save the page source. Send that page source to ryan at boren dot nu. Deactivate the plugin when you’re finished.

    Ryan thanks. I will give it a go…

    Ryan I have sent you an email today. Let me know If this is what you meant.
    Greetings

    I just had a problem with permalinks in a new install of 2.0. I had chmodded the .htaccess and let WP update that– and the permalinks didn’t work. Tried a couple things, like getting rid of the category, which I know was problematical in the past, but that didn’t work. So I restricted the chmod on .htaccess, did the permalink thing again, then MANUALLY edited the .htaccess file, being careful to make sure there wasn’t any trailing whitespace — and the problem was fixed.

    When you say you edited it manually, how exactly? What did you change?

    Well, if the file isn’t writable it will give you the text you need to put into the .htaccess file.

    That’s what fixed it for me.

    Unfortunately it’s broken again and all that was done was a few things were done in admin. Has ANYONE gotten Permalinks working PERMANENTLY in 2.0?

    I got the same issues here in 2.0

    I have the exact same problem. I DID fix it, though, by adding “index.php” to the permalinks so that it looks like this:

    /index.php/%year%/%monthnum%/%day%/%postname%/

    I have been working on this problem now for about 8 hours. very frustrating.

    The above URL works, but I would much much rather not have “index.php” in the URL… I hope there is a fix…

    Any advice?

    I am running WP 2.0.1
    My permalink structure is:
    /archives/%post_id%

    I have also tried:
    /%year%/%monthnum%/%day%/%postname%/

    Everything works fine.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Permalink / htaccess RC3’ is closed to new replies.
Skip to toolbar