WordPress.org

Support

Support » How-To and Troubleshooting » Permalink / .htaccess – Internal 500

Permalink / .htaccess – Internal 500

  • Hi:
    I generated the permalink code in Options -> Permalink, then created a .htaccess file and uploaded it to my server.
    WP is not my main directory, I uploaded .htaccess to mydomain.com/current/…
    1. Is this the right directory to upload?
    2. What step would I be missing if .htaccess is all you need? Do I need to flip on mod rewrite somehow?
    Thanks

Viewing 15 replies - 1 through 15 (of 15 total)
  • Try uploading it to your main directory, rather than current/

    Ok, I didn’t know if I could do that since WP is in the ‘current’ directory…

    TechGnome

    @techgnome

    Moderator

    matius – whoah! Slow down there pilgrim. Don’t go creating the directory structure. Using permalinks & the mod rewrite with .htaccess creates virtual directories. Meaning the folders don’t actualy exist. One thing to be sure is that your .htaccess file was uploaded as ascii/text and not binary (I’ve run into that problem once or twice). And DianeV is right, it should be in the root folder. It doesn’t matter where WP is after that since WP doesn’t actualy ever read that file. It’s used as a translator to change the URL from what you see in the browser into something that WP can actualy use.
    Tg

    Damn, so do I need to completely re-install now? I moved the .htaccess permalink structure code to the root folder and all of my original posts are screwed.

    Anyway to help this out?

    By the way, it seems to matter because I keep getting an Internal 500 Error when in this code is in the root folder.

    Moderator James Huff

    @macmanx

    .htaccess works only for the directory in which it is placed. Therefore, .htaccess needs to be in the directory where all of the wordpress files are.

    macmanx, that’s how it worked, but the posts above made me think that was incorrect…

    Should it matter that the WordPress files are in a folder called ‘current’. I put .htaccess in that directory.

    macmanx, that’s how it worked, but the posts above made me think that was incorrect…

    Should it matter that the WordPress files are in a folder called ‘current’. I put .htaccess in that directory.

    macmanx, that’s how it worked, but the posts above made me think that was incorrect…

    Should it matter that the WordPress files are in a folder called ‘current’. I put .htaccess in that directory.

    macmanx, that’s how it worked, but the posts above made me think that was incorrect…

    Should it matter that the WordPress files are in a folder called ‘current’. I put .htaccess in that directory.

    Sorry for the reposts- bloody Avant

    I’ve been getting this same error all week while trying to configure this in my .htaccess file.

    I finally tried making my .htaccess file writable (chmod) and pasting it via the WP control panel and it worked perfectly. Something about line wraps was screwing things up while editing the file via my FTP program (which sounds like the same thing TechGnome was talking about, above).

    Thanks for your response, but I still get an Internal Server Error- even when .htaccess is in the right spot.

    Moderator James Huff

    @macmanx

    Yes, your blog files are fine in /current/. And, if your blog files are in /current/, your .htaccess file should also be in /current/.

    I am pleased to find this thread, having had a bit of a problem with .htaccess.

    One of the things to check, if you get an error with .htaccess, is whether mod_rewrite is enabled on your server.

    You can also check your log files.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Permalink / .htaccess – Internal 500’ is closed to new replies.
Skip to toolbar