Permalink - Frontpage Mess (3 posts)

  1. Robinton
    Posted 3 years ago #

    (Note: I've been a accurate as I could here, but with a page or two deleted and my head spinning from the whole mess, I may have made an error or two in my reporting, although I don't think so. Sorry if I did.)

    I installed WordPress in the /news/ directory of my site. I want the URL of the home page (frontpage) of the WP installation to be http://mysite.com/news

    At first, it was. But then, I changed the permalinks to a custom setting:


    At that point, the URL of my WP frontpage changed to --


    -- with a "Page Not Found" message.

    When I put the proper URL in the browser window, it immediately switched to this. So first, the browser was taking me to a URL I didn't want, and then it was saying, "page not found."

    I DON'T want this permalink structure for my frontpage (or for any other ***pages*** on the site)! I want it only for the POSTS!

    I knew I could manually edit permalinks for a page, but I couldn't find anywhere to do this for the default page. So I created a new page, and set the permalink to mysite.com/news

    Actually, I think that worked, as far as it went. (Unfortunately, I can't recreate the situation right now, for reasons explained below.) However, the frontpage was now a static page. I wanted it to be a posts page. So I went to Settings / Reading Settings - and for Front Page Displays, "Your latest posts" WAS selected (as opposed to "Static page").

    Well, I wanted a posts page, so I deleted the page I had made, but the original "posts" frontpage didn't reappear even when I changed the permalinks setting back to what it had been. So I changed it back to the permalinks setting I want, and tried to create another page with the URL (permalink) mysite.com/news - but this time, it wouldn't let me do that, it automatically made it into mysite.com/news-2 so it must be seeing the earlier page mysite.com/news somewhere even though I had deleted it.

    And in fact, when I go to trash, I do see that page there -- but I don't see the original frontpage that got displaced by my first new page with the requested permalink mysite.com/news

    Pardon me for a minute, while I say GAAAARRRRRRRRRRRRR!!!!!

    Here's what I want.

    1) The frontpage is a "posts" page with the URL mysite.com/news

    2) Any other PAGES I create will also have a URL that does not include date, etc., but only mysite.com/news/preferred-page-name/

    3) POSTS have a URL like mysite.com/news/2012/04/27/category-name/post-title

    Can anyone out there lead me from the wilderness to the Promised Land?

    Thank you!


  2. RichardWPG
    Posted 3 years ago #

    I think you can have a look at this link. http://codex.wordpress.org/Using_Permalinks
    It might help you.

  3. Robinton
    Posted 3 years ago #

    Thank you, RichardWPG.

    I've now resolved the issue. Here's the solution.

    1) I retrieved my first "news" page from trash. The permalink was mysite.com/news

    2) Under Settings / Reading Settings, I chose "A Static Page"

    3) Under "A Static Page", I left "Front page" at "--- Select ---"

    4) Also under "A Static Page", I set "Posts page" to "News"

    5) I discovered that this installation had no .htaccess file in the installation root, so I copied one from another site.

    6) In the .htaccess file, I changed RewriteBase / to RewriteBase /news/

    7) In the .htaccess file, I changed RewriteRule . /index.php [L] to RewriteRule . /news/index.php [L]

    8) Above the other .htaccess commands I put Options +FollowSymlinks

    I don't know if this last item was needed. I picked it up somewhere. But anyway, this whole package worked.

    May this prove useful to somebody sometime -- but may no one else ever have to face this mess!


Topic Closed

This topic has been closed to new replies.

About this Topic