Support » Fixing WordPress » Permalink doesn’t work

  • 1. I’m using 1.5 stable.
    2. I’m sure my web server has turned on URL Rewrite in my directory.
    3. The “.htaccess” file IS writeable (chmod 666).
    4. I clicked the “Update Permalink Structure” button many times, it shows “Permalink structure updated.” with NO error. But actually, the time “.htaccess” last changed NEVER changes.
    5. So, I guess WordPress never update the file truely but reports the WRONG thing.

    I wonder whether there is a solution, thanks 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • Are you sure that your server is an Apache server?

    and is the .htaccess file in the wp root directory? Sounds like a stupid question but that was the mistake that I made last time

    Yes, I’m sure, because I’ve have tried to create .htaccess manually and it works, but the problem is that WP doesn’t generate it automatically for me…

    Could you please make a test.php with following content?
    [<?php echo $_SERVER["SERVER_SOFTWARE"];?>]
    … and post what you see when you access this link? Perhaps your host has disabled the SERVER_SOFTWARE variable that is used by WordPress to check if you’re really using Apache 🙂

    Oh, yeah, SERVER_SOFTWARE has been disabled, I modified wp-includes/vars.php and set $is_apache = 1, now is works.

    Thanks very much! 🙂

    Mmm. i have tried that as well , but no luck. Just get 404 pages.

    looks like it’s a common problem with the 1.5


    [Apache/1.3.31 (Unix) mod_python/2.7.10 Python/2.2.2 mod_gzip/ mod_webapp/1.2.0-dev mod_perl/1.29 mod_throttle/3.1.2 PHP/4.3.10 FrontPage/ mod_ssl/2.8.18 OpenSSL/0.9.7d]


    I’m having much the same issue. Upon upgrading my site from 1.2.2 to 1.5, my permalinks and monthly archives are not working – 404 error.

    Firstly, the monthly archives are presented in the format /archives/2005/01/post_name/, whereas I specified /archives/200501/post_id.

    The apache error_log reads:

    [Sat Feb 19 00:49:48 2005] [error] [client] File does not exist: /home/httpd/vhosts/, referer:

    and similar.

    Permalinks are presented in the correct format, but still 404.

    Categories work, as does Search, RSS, and other things relying upon mod_rewrite.

    ok, i have solved the problem.
    wordpress is writing the .htaccess in the root
    directory but would seem to be reading from
    the wordpress folder.

    i did a copy all (ctrl+a) of the .htaccess generated in the
    “Permalink” page. Created the .htaccess file local and copied
    it into the WordPress folder. works!

    i’m using the standard “/%year%/%monthnum%/%day%/%postname%/”


    oh, and don’t forget to chmod your .htaccess in your
    Wordpress folder 666


    sgwood… This isn’t good.

    When you create a new page, doesn’t WordPress update your .htaccess file automatically?

    Will you have to do this process each time you create a new “page”?

    Permalink works for my archives, but it doesn’t work for my PAGE. Should i create .htaccess too?

    I’m getting something similar, that I think is related, I just believe that I posted it in the wrong forum since it’s not “BETA” anymore.

    I am having a problem similar to that of <b>Insom</b>’s. I started using v1.5 gamma on a new server, to start building my new website and test out 1.5 before upgrading my real server. I upgraded 1.5 gamma to 1.5 strayhorn and my previous permalinks no longer work.

    I dont understand why this is happening, as it seems wordpress is just not using the permalink structure in the old post.

    I can create .htaccess and everything. when i update the permalink structure with wordpress, the new posts work, but the old ones still use the permalink structure that was inplace at the time it was written, on the old version

    Hi motoed,

    no, i don’t have to update the .htaccess every time. I am creating pages
    and i don’t have to update the .htaccess file.
    in fact, i checked the modified time on the .htaccess and then checked it again after creating a new page. the modified time remained the same.
    so the .htaccess wasn’t updated after each new page.

    in case it ain’t clear, i don’t have an .htaccess in the root, only the one that created in the wordpress folder.

    zpao, i would suggest that you:
    – delete all of your pages
    – delete any .htaccess files you have in root and in the wordpress folder
    – create a new .htaccess in the permanlink page with the structure
    – copy the new .htaccess into the wordpress folder
    – create a new page

    see if this works

    Same issue here. If I update the .htaccess file manually after creating pages (using options -> permalinks to create a new .htaccess file template) it works fine.

    Is there a second .htaccess file when wordpress is in the root of my website? WordPress seems to use the root one if I update it manually.


Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Permalink doesn’t work’ is closed to new replies.