Permalink - Custom Structure (12 posts)

  1. luisiher
    Posted 7 years ago #


    I am trying to custom my permalinks structure, however, when I do this for some reason my post pages get a 404 error, apparently this is because somehow I doubled up my domain url in my permalinks and set every post link to exactly the same broken url.

    Is there anyway that I can custom my permalinks and have access to the blog page.

    Please have a look Spanish http://www.spanish-aid.co.uk

    Thanks a lot

  2. What custom string do you want to use?

  3. luisiher
    Posted 7 years ago #

  4. Shane G
    Posted 7 years ago #


    Add this code in htaccess and have a check:

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress


    Shane G.

  5. First, turn on the regular permalinks and get that to work before trying to use a custom string.

  6. luisiher
    Posted 7 years ago #

    Sorry guys but it did not work. I did what Shane G suggested. and I am having the same problem with my post. The rest of the pages work perfectly but for some reason, when I click on one of my post the url duplicate itself http://www.spanish-aid.co.uk/http:/www.spanish-aid.co.uk/example#respond and I get the 404 error. I am going to leave it as it is so you can have a better look before I reset the permalinks to the default settings

    Thanks again for your help

  7. See, every single post permalink you have is wrong and set to this:

    What in the heck is in your custom permalink string? Because you obviously have set it incorrectly or something.

  8. luisiher
    Posted 7 years ago #

    Thanks, this has been ressolved however I still geting the duplicate url http://www.spanish-aid.co.uk/http:/www.spanish-aid.co.uk/2009/06/14/b-for-bravo-or-v-for-victo/ but as long as my readers can see my post that should be ok.

    Thanks for your help.

  9. Check your Settings->General page. Do you perhaps have something there with only one slash instead of two?

    Does your custom permalinks string contain that whole http thing? It shouldn't.

  10. luisiher
    Posted 7 years ago #

    Hi Otto

    I have checked my General setting and everything looks ok to me.

    this is what I have

    WordPress address (URL) http://www.spanish-aid.co.uk
    Blog address (URL) http://www.spanish-aid.co.uk

    My custom permalinks are like this.

    Custom Structure /http:/www.spanish-aid.co.uk/%year%/%monthnum%/%day%/%postname%/

    Do you thing I have to amend somthing?

    Thanks again for your help

  11. luisiher
    Posted 7 years ago #

    Otto man

    I just got it, I know what it was, I was putting the whole url again on my Custom Structure. I have deleted /http:/www.spanish-aid.co.uk and know is perfect. Sorry about this I thought I had to put the whole url when setting custom permalinks


  12. There's your problem.

    Change your custom structure to this:

    Just that. Not all the stuff in front of it.

Topic Closed

This topic has been closed to new replies.

About this Topic