WordPress.org

Forums

Permalink change caused disconnect (8 posts)

  1. e11studios
    Member
    Posted 1 year ago #

    When I changed the permalink in the admin section, the blog page went blank and said that the page couldn't be found. When I tried to log in, nothing happens. When I try to reset the password, I never get an email with a new one….HELP

    .htaccess code: RewriteCond %{HTTP_HOST} ^.*$
    RewriteRule ^blog\/?(.*)$ "http\:\/\/episodexistudios\.com\/video\-production\-blog\-nc\/$1" [R=301,L]

  2. govpatel
    Member
    Posted 1 year ago #

    It is possible that a .htaccess rule could be the source of the problem. To check for this, access your server via FTP or SFTP and rename the .htaccess file. If you can’t find a .htaccess file, make sure that you have set your FTP or SFTP client to view invisible files.

  3. e11studios
    Member
    Posted 1 year ago #

    Here is the entire htaccess file

    # compress text, html, javascript, css, xml:
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    
    # Use PHP 5.3
    AddType application/x-httpd-php53 .php
    
    # BEGIN WordPress
    
    # Enable expirations
    ExpiresActive On
    
    # Default directive
    ExpiresDefault "access plus 1 month"
    
    # My favicon
    ExpiresByType image/x-icon "access plus 1 year”
    
    # Images
    ExpiresByType image/gif "access plus 1 month"
    ExpiresByType image/png "access plus 1 month"
    ExpiresByType image/jpg "access plus 1 month"
    ExpiresByType image/jpeg "access plus 1 month"
    
    # CSS
    ExpiresByType text/css "access 1 month”
    
    # Javascript
    ExpiresByType application/javascript "access plus 1 year"
    
    </IfModule>
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTP_HOST} !^www\.episodexistudios\.com$ [NC]
    RewriteRule ^(.*)$ http://www.episodexistudios.com/$1 [R=301,L]
    
    RewriteCond %{HTTP_HOST} ^.*$
    RewriteRule ^blog\/?(.*)$ "http\:\/\/episodexistudios\.com\/video\-production\-blog\-nc\/$1" [R=301,L]
    
    AuthUserFile "/home/rdavis/.htpasswds/public_html/passwd"
    
    RewriteCond %{HTTP_HOST} ^e11studios.com$ [OR]
    RewriteCond %{HTTP_HOST} ^www.e11studios.com$
    RewriteRule ^/?$ "http\:\/\/www\.episodexistudios\.com" [R=301,L]
    
    Options +FollowSymLinks
    ErrorDocument 404 /404.html
    ErrorDocument 500 http://www.episodexistudios.com/index.html
    
    <Files 403.shtml>
    order allow,deny
    allow from all
    </Files>
    
    deny from 95.132.48.184
    deny from 62.5.128.0/17
    deny from 95.37.229.4
    deny from 123.26.110.209
    deny from 87.122.168.11
    deny from 79.77.131.24
    deny from 190.126.69.182
    deny from 84.223.152.100
    deny from 95.246.21.151
    deny from 94.75.34.135
    deny from 202.170.127.143
    deny from 41.130.68.6
    deny from 190.172.224.219
    deny from 88.108.203.231
    deny from 212.92.243.90
    deny from 77.247.28.96
    deny from 46.33.241.81
    
    # Google Analytics Integration - Added by cPanel.
    <IfModule mod_substitute.c>
    AddOutputFilterByType SUBSTITUTE text/html
    Substitute "s|(<script src='/google_analytics_auto.js'></script>)?</head>|<script src='/google_analytics_auto.js'></script></head>|i"
    </IfModule>
    # END Google Analytics Integration

    The website for the blog is http://www.episodexistudios.com/video-production-charlotte-nc

  4. govpatel
    Member
    Posted 1 year ago #

    Try and rename file and see if you get the site to open do not delete the file

  5. e11studios
    Member
    Posted 1 year ago #

    When I renamed the file, I could access it. I've look at how to write the ht access file but its beyond my technical abilities. So, I'm still trying to find where the error is within the htaccess file.

  6. govpatel
    Member
    Posted 1 year ago #

    I suspect this part of .htaccess file

    </IfModule>
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTP_HOST} !^www\.episodexistudios\.com$ [NC]
    RewriteRule ^(.*)$ http://www.episodexistudios.com/$1 [R=301,L]
    
    RewriteCond %{HTTP_HOST} ^.*$
    RewriteRule ^blog\/?(.*)$ "http\:\/\/episodexistudios\.com\/video\-production\-blog\-nc\/$1" [R=301,L]
    
    AuthUserFile "/home/rdavis/.htpasswds/public_html/passwd"
    
    RewriteCond %{HTTP_HOST} ^e11studios.com$ [OR]
    RewriteCond %{HTTP_HOST} ^www.e11studios.com$
    RewriteRule ^/?$ "http\:\/\/www\.episodexistudios\.com" [R=301,L]

    See if can copy the rest in your new .htaacess file and see if you get it to work

  7. e11studios
    Member
    Posted 1 year ago #

    This worked…thank you so very much.

  8. govpatel
    Member
    Posted 1 year ago #

    You are welcome

Topic Closed

This topic has been closed to new replies.

About this Topic