WordPress.org

Forums

Permalink / Breadcrumb structure issue with Page > CPTC > Post (2 posts)

  1. Atomix
    Member
    Posted 2 years ago #

    Hey guys,

    We're setting up some fairly large websites with lots of content and custom post types and have come to a bit of an issue with permalinks / breadcrumb structure following our menu..

    This is what we have setup in our Nav Menu:

    Services (Page)
    - Service Category (Custom Post Type Category page / Taxonomy / Archive Page)
    - Service Category (Custom Post Type Category page / Taxonomy / Archive Page)
    - Service Category (Custom Post Type Category page / Taxonomy / Archive Page)

    Each Service Category Archive page shows a list of Posts for that CPT / Category.

    Here is what happens...

    If you click Services then the url is this:
    http://www.site.com/services = great!

    If you then click on a Service Category the url changes to this:
    http://www.site.com/our_services/service-category-name = this is fine as the rewrite slug for the CPT category is our_services so that it does not clash with the page slug. However the url SHOULD be this:
    http://www.site.com/services/our_services/service-category-name
    OR even better, this:
    http://www.site.com/services/service-category-name

    So as you can imagine, the breadcrumb is the same, it loses "Services" and just says "You are here: Home > Service Category"

    If you then click on a Service... this is what happens to the URL:
    http://www.site.com/service/post-name = note it loses the "s" on services because thats what the CPT is called and it is different so that it does not clash with the page "Services".

    What it SHOULD look like is this...

    http://www.site.com/services/service-category/post-name

    Does anyone know how to set this up and get this working?

    Because of this I run into other problems like having a Left Sidebar Menu that should only show the Children of the Current Parent Menu item. So that doesn't work.

    Any advice would be great! - I've tried lost of things in CPT settings and permalink settings but mostly I just keep getting Error Pages (I'm assuming from conflicts in slugs).

    Thanks for reading and I appreciate and thank in advance any info or help given!

    Cheers

  2. Atomix
    Member
    Posted 2 years ago #

    Bump! - Can anyone help!?

Topic Closed

This topic has been closed to new replies.

About this Topic