Support » Fixing WordPress » permalink 404 issue in wordpress 3.1.3

  • Hi, I have just installed wordpress 3.1.3 and trying to changed my permalinks.

    I get a 404 Not found: The requested URL ‘….’ was not found on the server.

    I have installed WP on my local server. I have created an .htaccess file and get a ‘Permalink structure updated.’ message when I choose a new permalink, but then get the 404 error.
    The index.php file loads up fine, just any other links off this page.

    The only permalink that works if the default setting.
    I have search through the forum but unable to find any solutions.

    Any ideas? Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • delete your .htaccess file and try it


    what is your current permalink struture, that leads to the error?

    When you changed the permalinks did you get a message below the permalink area stating that it couldn’t write to your web.config file.

    If YES then you need to check your web.conig file and it should read something like this:-

    <?xml version=”1.0″ encoding=”UTF-8″?>
    <rule name=”wordpress” patternSyntax=”Wildcard”>
    <match url=”*” />
    <add input=”{REQUEST_FILENAME}” matchType=”IsFile” negate=”true” />
    <add input=”{REQUEST_FILENAME}” matchType=”IsDirectory” negate=”true” />
    <action type=”Rewrite” url=”index.php” />

    If it doesn’t – then open it up in notepad and change it.

    This should cure your problem.

    Also check your Permalink Structure conforms those laid in the link provided by Alchymyth.

    Hi all, thanks for the feedback / help so far.

    In response to suggestions:

    @ali-yazdi: tried, many times!

    @alchymyth: All I choose was the second permalink in the list in the wp admin area:

    @raystclair: No errors what so ever, and nothing saying it couldn’t write to anything. No mention of web.config file.

    web.config files reads like this – I changed it to what you typed above but no difference. Still 404 error.

    <?xml version="1.0" encoding="UTF-8"?>
            <directoryBrowse enabled="false" />
                    <clear />
                    <add value="index.php" />
                    <add value="Default.htm" />
                    <add value="Default.asp" />
                    <add value="index.htm" />
                    <add value="index.html" />
                    <add value="iisstart.htm" />
                    <add value="default.aspx" />
                <remove name="PHP via FastCGI (*.php)" />
                <add name="PHP via FastCGI (*.php)" path="*.php" verb="GET,HEAD,POST,DEBUG" modules="FastCgiModule" scriptProcessor="C:\Program Files (x86)\PHP\v5.3\php-cgi.exe" resourceType="Either" />

    Still no luck with this one – if I delete the .htaccess file it displays an error message when trying to save the permalink structure.

    Any ideas?

    Check your permissions on the server. Everything should be 755 except .htaccess in the main folder and wp-admin/index.php, which should both be 644. You should not have to create your own .htaccess file. WordPress should generate it when you turn permalinks on. Sounds like WordPress can’t write the file. What is the error message?

    Originally, before I created the .htaccess file. I got the following error messages.

    ‘You should update your .htaccess now.’

    ‘If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.’

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /~jwest/wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /~cskinner/wordpress_two/index.php [L]

    How do I check/change permissions on a mac?

    You can check/change permissions with FTP software or through your hosting control panel (via web browser). If you are on a commercial hosting server your hosting support people should also be able to set them for you.

    using a localhost MAMP. use filezilla.

    so I should really delete the .htaccess file I have create and change the permissions? when changing permissions using ‘getinfo’ I don’t see an option to enter a number (using mac OS 10.6)

    I don’t use Filezilla but you may have to check read, write and execute boxes accordingly to create the permissions.

    0 = — = no access
    1 = –x = execute
    2 = -w- = write
    3 = -wx = write and execute
    4 = r– = read
    5 = r-x = read and execute
    6 = rw- = read and write
    7 = rwx = read write execute (full access)

    So, 755 is rwx rwx rx.

    currently onto filezilla to find a way to edit the permissions –
    This issue with the .htaccess seams to come up a lot, such a common issue and never a simple solution…

    if anyone uses filezilla, I’m trying to connect to my local computer as a remote host (as this is the only way I can change the permissions – only works on files that I’m connected to remotely, for some reason when I right click there is not option to do this on locally connected files)

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘permalink 404 issue in wordpress 3.1.3’ is closed to new replies.