WordPress.org

Support

Permalink

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hey ho everybody,

    sorry that I have to come up with the same stuff, I updated my wordpresses today (to 2.6) and no permalinks are working any more, only 404 in most cases.

    Problem-blog:
    http://www.motorcityblog.de/
    permalink-structure
    /%post_id%-%postname%-%category%-%year%-%monthnum%-%day%

    sometimes here too
    http://www.h-quadrat.com/techblog/
    permalink-structure
    /%post_id%-%postname%-%category%.php

    What makes the issue interesting
    – my permalinks do not have index.php in them
    – non of the mentioned fixes (e.g. adding category and tag) are working

    So I would really appreciate if somebody could have an eye on that, ULRs dying on google webmaster tools makes me feel a little sick.
    This somehow sounds like a regex-problem to me, happens so often with rewriting … I sure can provide more details if needed.

    Regards,

    Henning

    ya.. same here, is it a bug for wp 2.6 ? but upon finding alot of those “sollutions” i still not able to fix it..
    sigh
    anyone can lend a hand here ?

    Maybe we just have to wait until a solution comes out. Or search one ourselfes but for me that is kinda impossible. I am going to check some regex in the htaccess but if the wordpress code causes the problem I have no chance to succeed.

    I have no problems with the custom permalinks in 2.6 (/%post_id%/%postname%/, so it’s not a WP thing.
    Firezz, is this the first time you edit the permalinks? Does your host support mod_rewrite? Did you read this article in the “Codex”?
    As for the rest, I had problems with permalinks after the upgrade from 2.3.1 to 2.5, but this was easily fixed by changing to default and back to “pretty”, apparently the htaccess had to be rewritten.

    Gangleri,

    it is for sure a wordpress problem because my wordpress is pretty much out of the box and the problems came right after the update from 2.5 to 2.6.

    I have long time programming experience with regex (in php and other languages) and mod_rewrite on apache, so I am relatively sure the problem was cause by the WP update.

    Maybe you don’t have %category% in your permalink-structure (or ‘-‘) and then the reg_ex doesn’t fail (and it works in your case even WP has a bug)? Maybe because the reg_ex is somewhat greedy or not?

    That should be checked by a WP-developer.

    Regards,

    Henning

    It works for 99% of the installations, otherwise there should have been much much more questions about this on these forums. Perhaps the problem of %category% or the dash is similar to that of index.php and the “devs” have to look into it. Did you already file a ticket?

    Btw. If you have long time programming experience, you could also compare older WP versions with the latest one on the subject (that’s way over MY head) to see if there’re changes that could be the cause of the problem.

    I could have a look inside the WP code if somebody gives me a point to start at for the url-rewriting but

    a) they have hopefully better people for that job
    b) I can not do WP code-mining of scratch because it would take a week or so

    I really hope somebody of the development team notices the problem.

    The “devs” don’t usually read the forums, so my suggestion is to gather as much information you can find and file a ticket at trac.wordpress.org.

    O.k., then I will file a bug. I didn’t know none of the devs are hanging around here.

    Thank you Gangleri.

    thanks hquadrat for the ticket 😉

    well i am not sure whether it is the wp 2.6 problem or not but one thing for sure, my previoous wp 2.5

    http://www.nendoroiz.com

    is def. working fine and i am able to get to any post with no prob. with the permalink ( just there is the /index.php/ only

    eg

    http://www.nendoroiz.com/index.php/who-is-this

    Well, i have try to google for solution and found out most of them said it is working fine while part of it says those methods isn’t working

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Permalink’ is closed to new replies.
Skip to toolbar