WordPress.org

Support

Support » Plugins and Hacks » Better WordPress External Links » [Resolved] Period in link apparently makes it appear as external

[Resolved] Period in link apparently makes it appear as external

  • We have BWP External Links set up so that all *.nasa.gov links are considered internal, (nasa.gov is a forced local domain), but the following sample links appears as external.

    The Puzzling Links:

    http://forms.grc.nasa.gov/Forms/PublicUser/index.cfm?fuseaction=SEARCH.searchDetails&form_id=9876543212
    
    https://esd.nasa.gov/secure/searchengine/AttachmentServlet.cfm?docid=RKM_9999&FileName=FileNameHere_v1[2].pdf

    I performed testing by removing special characters and non-letters:

    Links no longer appear as external when a period is removed:

    Remove period between “SEARCH” and “searchDetails”

    http://forms.grc.nasa.gov/Forms/PublicUser/index.cfm?fuseaction=SEARCHsearchDetails&form_id=9876543212

    Remove period between “AttachmentServlet” and “cfm”

    https://esd.nasa.gov/secure/searchengine/AttachmentServletcfm?docid=RKM_9999&FileName=FileNameHere_v1[2].pdf

    ===========

    Note: here are our forced local domains settings (though I’ve tried using just one of the following, not both, with the same results)

    *.nasa.gov
    nasa.gov

    Note2: I even tried adding the following fake domains as forced local domains:

    SEARCH.searchDetails

    AttachmentServlet.cfm

    http://wordpress.org/extend/plugins/bwp-external-links/

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Period in link apparently makes it appear as external’ is closed to new replies.
Skip to toolbar