Support » Plugin: Gallery Custom Links » Performance issues related to gallery link queries

  • Resolved dberdal

    (@dberdal)


    I really appreciate this plugin, but I’m noticing some performance issues with my database.

    I’m getting lots of queries like “SELECT ID FROM xxxxx_posts WHERE guid LIKE %someimage.jpg%”

    I don’t have the coding skills to fully analyze your plugin, but I’m wondering if the query is necessary? At least how I’m using the plugin, the images are inserted into the post using the wordpress gallery shortcode so the image ID is already available.

    I also noticed these:

    
    [Thu Jun 27 12:23:05.562413 2019] [php7:notice] [pid 3545] [client xxxxxx:44240] WordPress database error Commands out of sync; you can't run this command now for query SELECT ID FROM xxxxxxx_331_posts WHERE guid LIKE '%onedrop/wp-content/themes/Extra/images/logo.svg%' made by shutdown_action_hook, do_action('shutdown'), WP_Hook->do_action, WP_Hook->apply_filters, wp_ob_end_flush_all, ob_end_flush, Meow_Gallery_Custom_Links->linkify, Meow_Gallery_Custom_Links$
    [Thu Jun 27 12:23:05.576310 2019] [php7:notice] [pid 3545] [client xxxxxx:44240] WordPress database error Commands out of sync; you can't run this command now for query SELECT ID FROM xxxxxxx_331_posts WHERE guid LIKE '%wp-content/uploads/2019/04/featured-products.jpg%' made by shutdown_action_hook, do_action('shutdown'), WP_Hook->do_action, WP_Hook->apply_filters, wp_ob_end_flush_all, ob_end_flush, Meow_Gallery_Custom_Links->linkify, Meow_Gallery_Custom_Link$

    I’m using this plugin on wordpress multisite. I have it activated network wide, and a few of my users are using it on their blogs… however, the slow queries being recorded are for the root site posts table, and I’m not using the plugin on the root site.

    I’m wondering if I’m noticing an issue specifically related to wordpress multisite.

    Let me know if I can provide any extra info

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Performance issues related to gallery link queries’ is closed to new replies.