Antispam Bee
Performance Issues - Had to Disable (1 post)

  1. ThinkD
    Posted 2 years ago #

    ASB is a fantastic plugin and I have been using it for a long time without any problems but this morning I received a request from my host (WPENGINE) to disable it because of 700 slow database queries

    There comment

    Your site is registering upwards of 700 slow queries all around the wp-comments-post.php and the antispam-bee plugins. I have attached a snippet from the slow query log to show to you.

    The plugin has to scan 85 thousand rows and sometimes sends no data back. I would suggest sending this slow query log over to the plugin author so they can look into optimizing the queries and perhaps utilize object cache

    I think the problem is the site is pretty comment heavy with over 85 thousand comments at the last count so I guess when ASB is looking at the database for previous commenters it is struggling with the size of it.

    Since I switched it off I have been deluged with spam even though I have implemented a few other plugins as a stop gap measure which goes to show just how effective ASB is.

    I could send you the log snippet if it helps but was wondering if there is any setting I would implement to reduce the load


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Antispam Bee
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

  • RSS feed for this topic
  • Started 2 years ago by ThinkD
  • This topic is not a support question
  • WordPress version: 3.6


No tags yet.