Support » Plugin: Modern Events Calendar Lite » Performance issues

  • Resolved niklas04

    (@nikla04)


    Hi,
    I love the Modern Events Calendar plugin.
    Unfortunately, I have some performance problems (using it with Enfold theme).
    The loading times of the pages (backend and frontend) are minimum two times higher.
    If I want to edit a page the loading time is even 6 sec with MEC enabled instead of 1,5s sec.

    I tried to locate the issue and had success:
    It is located in the “import”-function in the “mec-init.php”-file.
    I figured out that the query of “file_exists” increases the loading time of the pages.
    (Maybe it is caused because the “load_features”-function and “load_skins”-function calls the “import”-function so many times.)
    I’m still not sure if the performance issue is related to the Enfold theme. I’d tried the 2019 WordPress theme and had lower page load times, but they are still higher as when MEC was disabled.

    Maybe you can figure out what the problem is or find another solution for this query.

    For now, I’ve set the override-variable to false, because I don’t need the override-function.
    Maybe you can at least provide a filter to disable the override-function.

    Best regards
    Niklas

    Appending some page load times (measured with Query Monitor):
    https://drive.google.com/file/d/1yPoUGvg_RnaZ20gpaRItPBt-B75DAcCy/view?usp=sharing

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Webnus

    (@webnus)

    Hi @nikla04,

    Thanks for contacting us,

    First of all MEC is compatible with PHP 7.0.x – 7.1.x – 5.6.x versions.

    With regard to the low speed of your website’s loading:

    Deactivate all your plugins event MEC and let the MEC remain active only, set your theme on default, then reload the page, if the issue was solved, then activate your plugins one by one and your theme, refresh your page and check to see which plugin is causing the issue. Please let us know the results.

    We integrated the MEC with WordPress cash plugins and also we created a built-in cash, and I should add we used MVC structure for coding which is we could introduce the lightest plugin into the market up to this date. We have installed on several hosts and have done several Google speed tests, you activate and deactivate the plugin and then test it via Google https://developers.google.com/speed/pagespeed/insights/ or https://gtmetrix.com and see the results. We have also tested MEC on the weakest hosts, it is possible that your server is not optimized for WordPress, we recommend using hosts which are optimized for WordPress: https://wordpress.org/hosting/.

    If the issue was caused by MEC let us know, however, first check whether the configuration of your WP is ok: https://webnus.net/deep-premium-wordpress-theme-documentation/what-are-best-wordpress-php-settings/ Also you need to make sure that cURl is enabling in your website (contact your host provider to enable it for you)

    If MEC was not faulty contact your host provider for your website’s TTFB: https://en.wikipedia.org/wiki/Time_to_first_byte

    Open developer tools of your browser and select network tab: https://developers.google.com/web/tools/chrome-devtools/network

    Warm Regards,

    Thanks for your answer!

    I did deactivate all plugins except MEC. I measured the page load times of frontend- and backend-pages with GTmetrix and Query-Monitor-Plugins.

    The first test is done with the Enfold theme.
    After deactivating all plugins except MEC there is no big difference in loading times.

    After deactivating MEC the loading time has decreased. Something I noticed in GTmetrix, is that the waiting-time of the GET-Request (TTFB) decreased by three times or more after deactivating MEC.

    As mentioned in my beginning post, I think the problem is located in the “import”-function of the “mec-init.php”-file. After setting the “override”-variable to false, I experience similar loading times as with MEC deactivated.

    In a second test run, I switched the theme to the default “Wordpress 2019” theme.
    With all plugins enabled I measured some slightly lower loading times compared to Enfold themes.
    Of course, I measured times with all plugins disabled except MEC. No big differences.
    Then I deactivated MEC and the loading times decreased.

    I’m using PHP-version 7.2.22 and have PHP-boost enabled.
    Even after switching to PHP-version 7.1 or disabling PHP-boost, there is no different in loading time (sometimes even higher than with original configuration).

    cURI is enabled on my server.

    Have the following Host configurations:
    upload_max_filesize = 64M
    post_max_size = 76M
    memory_limit = 256M
    max_execution_time = 120
    max_input_vars = 4000
    max_input_time = 60

    I’d tried to increase max_input_vars and max_input_time to your recommendations, but there are no differences in loading times.

    Here are the measurements – if you need them:
    https://drive.google.com/file/d/103YA4wnU5R_p9wrqsMrM7powSAwSRvGt/view?usp=sharing

    Plugin Author Webnus

    (@webnus)

    Hello,

    Could you please send live URL from your issue? so, we’ll get back to you very soon.

    Increase Page Speed on our documentations:
    https://webnus.net/deep-premium-wordpress-theme-documentation/increase-page-speed/

    Best Regards

    I’m sorry for the late response.

    Here is the URL of my site:
    http://dev.frankenballon.de/
    On this site all plugins excluding MEC are deactivated.

    This is my live site:
    https://frankenballon.de/
    Of course all plugins activated and applied the temporary fix for MEC (as desricted in my previous post).

    I’ve done these steps to increase Page-Speed:
    Caching, Image-Optimisation, CSS and JS compression, clean Database
    Of course, some of these are inactive on http://dev.frankenballon.de because plugins are deactivated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.