Support » Fixing WordPress » People can’t leave comments because they are “suspected bots”

  • Hi,

    I’ve seen this question posed before but the fix, delete the MOJO Marketplace plugin, doesn’t apply to me. I don’t have that plugin, and I have already tried deactivating all of my other plugins. And yet, people who try to comment are still unable to. They get the message that they are “blocked as a suspected bot.” What else can I try to do to fix this?

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • I was able to leave a comment on your blog with a disposable email.

    I didnt get any “bot” message.

    Thread Starter pinkcaddytravelogue

    (@pinkcaddytravelogue)

    Thank you! I deactivated the Bluehost plugin, the only one I hadn’t yet, and that seems to have fixed it.

    Yep, does seem to be the Bluehost plugin, I thought this one would be okay but I just had someone with this same issue. They probably wrapped up the Mojo Marketplace into this new plugin they’re installing.

    Thank you! This thread just saved me so much time, I’ve been having the same issue and couldn’t find Mojo Marketplace. Deactivating Bluehost did the trick for me too.

    Deactivating Bluehost worked for me as well! Thank y’all!

    Hi there! I am having this issue as well… I do not have the Mojo Marketplace plugin but DO have the bluehost plugin.
    Is it safe to deactivate it? Don’t I need that plugin for my site to be connected to bluehost??

    Hi everyone,

    I come here from Google searches. Since this issue happens quite often, I’d like to give some insights for a quick solution.

    If you see “Blocked as suspected bot”, it is caused by Bluehost or Mojo Marketplace plugins. Solution: you can temporarily disable these plugins or better contact your hosting provider Bluehost to get help.

    —–

    The following information is pretty technical, you may ignore it 🙂

    “Blocked as suspected bot” can be found here https://github.com/mojoness/mojo-marketplace-wp-plugin/blob/master/inc/spam-prevention.php#L135

    The code line may be changed but the code looks like this:

        $spam_key = md5( $_SERVER['HTTP_USER_AGENT'] . $_SERVER['REMOTE_ADDR'] );
        if ( ! isset( $_POST['js-spam-prevention'] ) || $_POST['js-spam-prevention'] !== $spam_key ) {
            if ( current_filter() !== 'registration_errors' ) {
                die( 'Blocked as suspected bot.' );
            } else {
                $data->add( 'bot_error', 'Suspected bot.' );
            }
        }
    

    Just wanted to say I had the same issue. I deactivated the Bluehost plugin and it fixed the problem. I chatted with support to see what would happen with removing the plugin and he asked which Bluehost plugin I was talking about. Long story short, MOJO marketplace IS the Bluehost plugin (when you deactivate it it shows as MOJO Marketplace as the name NOT Bluehost). He stated this about the MOJO plugin: It is default plugin. It is used for staging websites. It is recommended not to use it at the moment, as it is a beta version.

    Just wanted to let anyone else know that might have the same problem, because I am VERY new to this and learning a LOT the long, hard way lol.

    @mpatroni so it is safe to deactivate the ‘bluehost’ plugin? Even though it says ‘bluehost’ and not Marketplace MOJO?? I am hesitant to do so… what are the repercussions? Really nothing??

    I have had no problems deactivating it. The agent I spoke with from bluehost recommend I deactivated it as well. Once you deactivate it go to your inactive tab and you will see that it shows as Mojo NOT bluehost. The name is misleading when active. It won’t affect your hosting.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘People can’t leave comments because they are “suspected bots”’ is closed to new replies.