Support » Plugin: TheBunch KE Pesapal Gateway for Woocommerce » Pending payment status in orders

  • Resolved kelvinwp

    (@kelvinwp)


    Hello,am seeking help with the plugin not updating status of order as paid even after funds have been received by pesapal.On our site orders page it still indicates the status as pending payment. Kindly assist. I have the latest WP version and the latest plugin update.

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author Paul Kevin

    (@rixeo)

    Hello @kelvinwp,

    Hope you are well today. Kindly verify if you set up the PesaPal IPN URL defined in the gateway settings.

    Thank you

    You mean this part?:To handle APN return requests, please set the url http://yallo.co.ke/?wc-api=WC_Pesapal_Gateway in your PesaPal account settings

    Its APN return requests in the gateway settings ….cant see any IPN URL…i have set Merchant IPN (Instant Payment Notification) Settings in pesapal as above URL :http://yallo.co.ke/?wc-api=WC_Pesapal_Gateway

    Plugin Author Paul Kevin

    (@rixeo)

    Hey @kelvinwp,

    Thanks for the feedback. Please check latest release that fixes the IPN URL.

    Warm Regards
    Paul Kevin

    Still not working, am happy to share screenshots….kindly share your email address..mine is kevweru@gmail.com

    Plugin Author Paul Kevin

    (@rixeo)

    Hello @kelvinwp,

    Will send you an email shortly.

    Thank you

    See screenshots on email….thanks for rapid response, great service….lets solve this one.

    Hello, thanks for helping but IPN still not updating order status in woo-commerce orders….

    Plugin Author Paul Kevin

    (@rixeo)

    Hey there @kelvinwp,

    Hope you are well today. I am currently working on a solution for this and I will update you via email in the next few days.

    Warm Regards
    Paul Kevin

    Tried in HTTP mode didn’t work, tried again in HTTPS didn’t work, but transactions on pesapal account are okay.On woocommerce all orders are indicated as “pending payment”

    Plugin Author Paul Kevin

    (@rixeo)

    Hey there @kelvinwp,

    Did you remove the redirect your site does when someone visits it on http? If you have an SSL certificate on the site, its best to set the site url in your “wp-admin > settings > general” to https to avoid the unwanted redirects that can cause the webhook to fail

    Hi, thanks for the reply….site url in your “wp-admin > settings > general” Already set to https, always been see screenshot on email.

    Thanks, let me know if i can do anything to help solve the problem…

    I have the sama problem as @kelvinwp stated, in fact when a user/costomer buy a downloadable product using pesapal the user won’t download such product after completing payment instead a staff should manually change order status from pending to processing so as a user can continue. please assist us.

    I have the same problem.

    • This reply was modified 1 year, 1 month ago by herman3.
    Plugin Author Paul Kevin

    (@rixeo)

    Hello,

    Its an issue with PesaPal. Please contact them directly to have this resolved. There are some changes they have done that are affecting IPNs

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.