WordPress.org

Support

Support » Plugins and Hacks » PDW Media File Browser » PDW Media File Browser Plugin Problem

PDW Media File Browser Plugin Problem

Viewing 15 replies - 1 through 15 (of 19 total)
  • Problem solved:)

    In a file ‘config.php’, line 62, I changed path to ‘admin.php’ from ‘/wp-admin/admin.php’ to ‘wp-admin/admin.php’ and in the same file, line 106, I Changed $uploadpath = $_SESSION[‘wp-content/’]; to $uploadpath = $_SESSION[‘wp-content/my-path-to-file-storage’];

    Works like charm right now! 🙂

    Too soon to be happy. After few housr of fine working something strange started to happen, and I don’t know what’s going on. I started a new project in WP. my gallery/image folder full path is ‘http://localhost/wp/wp-content/themes/ecocar/galeria’ where ‘http://localhost/wp’ is the root dir for WP. I changed path to upload folder in ‘config.php’, and it looks like that righ now: $uploadpath = $_SESSION[‘/wp-content/themes/ecocar/galeria’]; . Everything should be fine, but it isn’t. When I go to ‘Media’ in WP dashboard and I choose PDW File Browser, it shows folders in the root of my server, which is ‘http://localhost’. What’s more, all icons there look like folder icons, even image files. I need to mention I use XAMPP on WiN 7 x64. When I click ‘wp’ folder icon, it gives me warning message: Warning: filemtime() [function.filemtime]: stat failed for D:\Strony\xampp\htdocswp/ in D:\Strony\xampp\htdocs\wp\wp-content\plugins\pdw-file-browser\pdw_file_browser\file_specs.php on line 44; , and when I doubleclick on the same folder it shows ‘The folder path was tampered with!’. ‘D:\Strony\xampp\htdocs\wp’ is the folder with WP installation on my Hard Drive. I hope somebody’ll help me. Thanks in advance!

    regards

    I had the same problem, and contacted the author directly.
    He has now updated the plugin, and the problem with the wp-root should’ve been fixed 🙂

    The plugin had issues with localhost, but that’s also fixed in the new version!

    I’v used the plugin in 2 websites, one works just fine, but on the other one it won’t upload images and images uploaded through FTP will not show a thumb, but only show a filename with a picture which says “Usage…. read usages comments for details” CHMOD is 755, not sure which PHP version.

    Media library works just fine.

    I don’t know which setting to change, help!

    Same here, folder path uses localuser. So i still don’t know what to do. On my other website, with a different hostingservice it works fine.

    I have the same “wp-root” is not defined via $_GET” issue.
    I’m using ver 1.3, but it doesn’t start.
    Is there any fix?
    thanks,
    Udo

    Udo, I had the same issue, when you go to PDW’s options you should to be able to choose language and skin for the plug-in. Do it, and you receive a message that options are saved. Then go to PDW in Media folder in WP Dahboard and it wil start automatically. That’s what worked for me…

    …But apart form that I contacted author via e-mail as well. He told me to check all other plug-ins and reinstall WP, so I did. It was when v 1.3 was just released. 1.3 worked fine until now, but only on Chrome. Opera, Firefox and IE don’t want to display a pop-up window when placing an image into page or post, a message about browser’s callbac in javascript is displayed in web broeser’s status bar and nothing happens….I work with XAMPP installed on Win 7 x64. Maybe anyone has an idea why Opera, IE and FF don’t cooperate with the plug-in?

    Cheers and thanks.

    Mhh, sounds good, but my problem is, that I can’t get the options. When I chose the options tab, I just get the error message: `Error

    “wp-root” is not defined via $_GET`
    I will try to disable all other plugs and see what I get….
    thanks,
    Udo

    By the way, I use chrome as well, but only online on my wp installation.

    ok, disabled all plugins, deinstalled PDW Media File Browser, reinstalled wordpress, reinstalled PDW Media File Browser…. same error message on calling the options….
    perhaps the author can help, I dosnt know what to test anymore…..
    Is he in this support forum? dis not read any answer from him on any question… 😉

    Udo, try to do something opposite then. Go to media folder and try to open PDW. You should get an error. Then go to PDW options and choose language and skin. and then go back to media folder. Try in exactly that order.

    ok, now I get the message Upload folder doesn't exist or $uploadpath in config.php is set wrong! in both, options and media folder.

    I got tham message when I tried to use v1.2 of the plug-in. After installing v 1.3 it was ok until yesterday. The plugin doesn’t work on all web browsers I tried: Opera, Firefox, Internet Explorer 9 or Chrome. I have no idea why…But I didn’t try on Mac, only on Win 7 Ultimate x64…

    Udo, if you still have the message about upload folder, propably something’s wrong with..the upload path in ‘index.php’ of the plug-in. Open it with any editor (I use Dreamweaver) and go to line 71. There is a need to write down a path to your upload folder. By default it’s ‘wp-content/uploads/’. Be cautious, don’t put “/” at the beggining, but it’s essential to put it at the end. If it’s written in a different way change it, so it looks like an example I give you: my upload path is ‘wp-content/themes/ecocar/galeria/’. It should get rid of a warning, that something’s wrong with your upload folder.

    I checked back in what order you should choose options in WP dashboard to make PDW work. It’s PDW Media Browser in Media folder first, and then you should be able to choose options. If do it in opposite way you will get a message about ROOT problem.

    PS: don’t change upload path in config.php, only in index.php…it worked for me that way.

    Greets.

    The change log mentions this issue is fixed however I just installed it fresh for the first time and get the same “wp-root” is not defined via $_GET error. I’ve tried the ordered steps detailed in this thread as well as checked the index file.

    hi… we are using wordpress’ multisite feature (WP 3.4.1) and have set up ca. 10 blogs in one installation. now we would like to give PDW a try. but, unfortunately, we get the message
    Upload folder doesn’t exist or $uploadpath in config.php is set wrong!

    According to the hint above, I have tried to change line 71 of ‘index.php’ to different values, but without success…

    by default, the blogs put down their files not in
    ‘wp-content/uploads/’
    but in
    ‘wp-content/blogs.dir/XXXX’ where XXXX is the ID of the blog.
    the index.php/line 17 does not accept this/these paths(s)

    #Can anyone help me?

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘PDW Media File Browser Plugin Problem’ is closed to new replies.
Skip to toolbar