Support » Plugin: Media Library Assistant » PDF will not generate thumbnail

  • Resolved nickchia


    Hi David,

    I just uploaded a new PDF and it will not generate a thumbnail. Why is this happening.See “Seaside Case Study” under Food and Beverage heading.


    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author David Lingren


    Thanks for your report and for including a link to the document.

    I downloaded a copy of the Clayton-Seaside-Case-Study-2021_Feb-opt.pdf document and uploaded it to my test system. WordPress generated the thumbnail without any problems that I can see.

    You can try using MLA’s thumbnail generation function to correct the problem:

    1. Navigate to the Media/Assistant admin submenu.
    2. Check the box to the left of the document.
    3. Pull down the “Bulk actions” list, select “Thumbnail” and click “Apply.
    4. Leave the “Type (o) WP” selection in place.
    5. You may have to change the “Existing items” selection to “Delete”, but try first with the “Keep” default.
    6. Click “Generate Thumbnails”.

    I will leave this topic unresolved until I hear back from you on whether this worked.

    Thread Starter nickchia


    I fixed it by applying these steps from your reply to danielmelnechuk (@danielmelnechuk) from 1 year 1 month ago, “One PDF thumbnail not showing after replacing with new PDF.”

    I followed these steps:

    1. Navigate to the Media/Assistant admin submenu.
    2. Check the box to the left of the bad item.
    3. Pull down the Bulk Actions dropdown, select “Thumbnail” and click “Apply”.
    4. Verify that the Type radio button is set to “WP”.
    5. Change the “Existing Items” dropdown to “Delete”
    6. Ignore the “-Thumbnail” value in the Suffix text box. It does not apply to WP thumbnails.
    7. Click “Generate Thumbnails”.
    8. Check the return message at the top of the screen and look for a thumbnail in the table.

    IMPORTANT: I only needed to get to step #3 to fix the issue.

    Thread Starter nickchia


    Thanx David,

    I actually figured it out while you were looking into it (see my response above). Again, thank you for being o responsive to my question. You are always right on top of issues and I really appreciate it.


    Thanks both for this as I had same issue and the above resolved it 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PDF will not generate thumbnail’ is closed to new replies.