Support » Plugin: Asgaros Forum » PDF upload issue

  • Resolved gamark

    (@gamark)


    Hi there,

    I have an issue with one of the later updates. When I try to upload a PDF file as attachment to a post in the forum, the preview is not working.

    How can I disable PDF file preview in the forum post and just show the link description or the file name?

    Thanks.

    George

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Asgaros

    (@asgaros)

    Hello @gamark

    Thank you for your bug-report. I will have a look into it when I am back from Asia next week. If it is a bug, I will try to fix it in the next version.

    Plugin Author Asgaros

    (@asgaros)

    Hello again, @gamark

    I just tested the upload with PDF-files and everything is working fine for me. By default there should be no preview-images for pdf-files so thats why there is also no way to disable a preview-generation for it. Is the upload-functionality generating a preview-image for your pdf-file? Normally, only a link should be shown at the end of posts in the “Uploaded files”-list.

    Thread Starter gamark

    (@gamark)

    I will have a look further in the code… it may be something else on my side. But I have not changed anything except for updates on the forum plugin. Strange enough that all other files types are ok, except for PDF. I will look into this further. Thanks for your time and good job on the functional plugin.

    Any thoughts into placing privileges rights to forum sections? It would be a supper great feature to be able to create a forum and sub-forums and then just also be able to give permission rights.

    You know what I mean with this: admin only section or Editor level required to see certain section and so on.

    Plugin Author Asgaros

    (@asgaros)

    Hello @gamark

    I will check the pdf-issue also again when I am back from Asia because I am only having a limited testing-environment here.

    Yes, advanced privileges will also come in a future update, but I have no ETA for it yet.

    Plugin Author Asgaros

    (@asgaros)

    Hello @gamark

    You were right! The forum tried to generate thumbnails for pdf files which is not working because they are not image files. I fixed it in the development-version:
    https://github.com/Asgaros/asgaros-forum/commit/7212106ac1638199780b54db6e80d55baa9c6618

    It will also be included in the upcoming v1.4.5 release.

    • This reply was modified 5 years, 4 months ago by Asgaros.
    Thread Starter gamark

    (@gamark)

    Super Asgaros, thanks for that. I updated my site and all good.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘PDF upload issue’ is closed to new replies.