Support » Plugin: Foyer - Digital Signage for WordPress » PDF Slide not saving

  • Resolved bmulckhu

    (@bmulckhu)


    Already using Foyer for some time; it’s great and thanks for your development.
    Today I encountered a problem when creating a (multipage) PDF Slide: Foyer won’t let me save the slide with PDF. De slide will not show any content (just black).

    What I did:
    – I uploaded and saved a multipage PDF (3,4 MB), no problem here
    – I created a new slide in Foyer, selected PDF slide – works fine
    – Then selected the previously uploaded PDF to the slide; no problem (thumbnail shows on slide).
    – Then i preview the slide: black screen
    – Then I save the slide: connected PDF is gone from the slide

    I tried several variations, but it will not work. I’m using PHP 5.6, WP 4.8 and Foyer 1.7.3

    Thanks in advance for helping!

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Menno Luitjes

    (@mennolui)

    Hoi Bart!

    Let’s see if we can troubleshoot this together.

    Did you save the slide before previewing? If so.. did you try other PDFs, maybe a simple one with just text, and did any of them work? If so.. could you send me the PDF that won’t work, via this link: https://foyer.tv/send-info/

    If none of the PDFs work, could you turn on WP_DEBUG (https://codex.wordpress.org/Debugging_in_WordPress) and send me any error messages that appear when saving and when previewing? Hope that’ll tell us something about what is going wrong.

    Groet!

    Hi Menno,

    Thanks for coming back on this issue!

    @question-1: I tried both workflows: first previewing the slide then saving it, and: first saving it before previewing. Both result in a “black” preview and the PDF is disappeared after de slide has been save.

    @question-2: Yes I tried a “smaller” PDF as well; same results as before. I will send you the PDF.

    I will try turning on WP_DEBUG and come back here with the findings…

    Gegroet, Bart.

    • This reply was modified 1 year, 10 months ago by bmulckhu.

    Putting on WP_DEBUG does not give extra info.

    I noticed that WP does give a warning:

    Verwerken van PDF pagina’s mislukt.
    Zorg ervoor dat je WordPress versie 4.7 of hoger gebruikt, en Imagick met Ghostscript aanwezig is op je webhosting.
    Foutmelding: Niet mogelijk om editor te selecteren.

    Probably this helps to find the cause… 🙂

    I checked with my webhoster, and Imagick with Ghostscript is available on my server.

    Problem is persistent, though…

    Plugin Author Menno Luitjes

    (@mennolui)

    Ha Bart,

    Thanks for troubleshooting. Your PDF shouldn’t be the problem. I’ve added the PDF to a PDF slide in a test environment running PHP 5.6 and WordPress 5.0 and this worked without a problem or error message.

    I expect something is not correctly set up at your hosting provider (Imagick with Ghostscript) or there is something specific to your WordPress + plugins install.

    If you want I can take a look at your hosting set up. Can you add an info.php file to your website root containing this single line..

    <?php phpinfo();

    ..and send me the URL where I can view that info.php page (using my form, not here)

    Also, could you test creating a PDF slide..

    – On a WordPress install (preferably 5.0 or higher) on a different hosting provider, or
    – On a local copy of your website, or
    – After temporary disabling all plugins on your website, maybe upgrading to WordPress 5.0 or higher

    Hope this will reveal what causes the problem!

    Hi Menno,

    The php info-link has been sent. Let me know what you find out!

    For the other requests I need some more time…
    I can add that I’m using Foyer in a WordPress Multisite environment; would that be an issue?

    Plugin Author Menno Luitjes

    (@mennolui)

    Hoi Bart,

    Foyer on multisite works fine, no problem there.

    From your phpinfo I can see the Imagick module is missing. Maybe your hosting provider is right and Imagick is available on the server somewhere, but from what I can see it is definitely not available to PHP (and WordPress / Foyer). In the phpinfo page there should be a block called ‘imagick’. Copy from the phpinfo page of another PHP 5.6 hosting environment:

    imagick
    imagick module	enabled
    imagick module version	3.4.3
    imagick classes	Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator, ImagickKernel
    Imagick compiled with ImageMagick version	ImageMagick 6.8.9-9 Q16 x86_64 2017-11-16 http://www.imagemagick.org
    Imagick using ImageMagick library version	ImageMagick 6.8.9-9 Q16 x86_64 2018-05-18 http://www.imagemagick.org
    ImageMagick copyright	Copyright (C) 1999-2014 ImageMagick Studio LLC
    ImageMagick release date	2018-05-18
    ImageMagick number of supported formats:	215
    ImageMagick supported formats	3FR, AAI, AI, ART, ARW, (...) PDF, (...)

    I expect you’ll find PDF slides will work once Imagick (with Ghostscript / PDF support) is available to PHP on your hosting environment!

    Let me know if this works..

    Hi Menno,

    Thanks for helping me out: this solved the issue.
    Foyer is now running smoothly with PDF.

    Plugin Author Menno Luitjes

    (@mennolui)

    Cool! Great to hear.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘PDF Slide not saving’ is closed to new replies.