• Resolved BigBlack

    (@bigblack)


    I’m trying to load a pdf, it’s about 18 mb. It’s not loading. I’m working on local Xampp now. The widget load correctly, it show the page number but it’s not loading pages. What to do?

Viewing 15 replies - 1 through 15 (of 15 total)
  • jenniferklibby

    (@jenniferklibby)

    I am having this exact same problem, and my pdf is 23MB. I have looked through the documentation to see if perhaps there is a size limit but came up empty.

    ChaseC

    (@chasec)

    We are having the same issue in that NONE of our PDFs are loading on the pages anymore at rocketstem.org. The problem seems to have appeared in just the last week. Our best guess is that it might be related to the WordPress 5.4 update.

    We can verify that it is NOT size related, as our PDFs range from a mere 2-3 MB up to around 70 MB and this issue has affected them all.

    • This reply was modified 4 months ago by ChaseC.
    ChaseC

    (@chasec)

    Thank you for the update released in the past day, however, it does not appear to have fixed the problem. PDFs still are not loading under WP 5.4.

    @bigblack and @chasec,

    I found that if I manually uploaded a jpg of the cover of my book as the thumbnail, it would then load the rest just fine. It seems that if you do not, the plugin tries to create a thumbnail based on the first page of the pdf and that’s causing issues. I’m not certain this will fix your issue, but it worked for me.

    Thank you @jenniferklibby, Unfortunately that did not fix the issue for our site. The whole situation has gotten even stranger though as I’ve discovered that the plugin loads the PDFs fine on the mobile version of the website, but they are still nonexistent on the desktop version of the site.

    The plugin loaded PDFs fine for several months, and only seems to have gone haywire somewhere around the time that WP 5.4 was released. Coincidental, perhaps.

    IGNORE my previous posts about an issue with PDFs loading. Still can’t explain it, but the problem only exists on my desktop computer. Have used an iPhone, iPad and MacBook Pro and the PDFs load fine on each of them. Apparently, my iMac is just acting flaky at the moment.

    Sorry for being the boy calling wolf!

    Still problem here.. I tryed also to add the cover image but nothing solved..

    Plugin Author iberezansky

    (@iberezansky)

    Checked on WP 5.4 – works fine. Probably there are some conflicts with other plugins or the theme. Also check debugging console Ctrl+Shift+I – any errors?

    These are the warning found:

    pdf.worker.js:1 The provided value ‘moz-chunked-arraybuffer’ is not a valid enum value of type XMLHttpRequestResponseType.
    e @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    e @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    pdf.worker.js:1 The provided value ‘moz-chunked-arraybuffer’ is not a valid enum value of type XMLHttpRequestResponseType.
    e @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    e @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    pdf.worker.js:1 Warning: Could not find a preferred cmap table.
    pdf.worker.js:1 Warning: Could not find a preferred cmap table.
    three.min.js?ver=5.3.2:154 THREE.WebGLRenderer 84
    pdf.worker.js:1 The provided value ‘moz-chunked-arraybuffer’ is not a valid enum value of type XMLHttpRequestResponseType.
    e @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    e @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    (anonymous) @ pdf.worker.js:1
    2pdf.worker.js:1 Warning: Could not find a preferred cmap table.
    pdf.worker.js:1 Warning: TT: more functions defined than expected

    some ideas?
    You can see the result there http://35.214.200.56/~inoxwher/temporaneo/modelli-banchi-pesce/

    • This reply was modified 3 months, 1 week ago by BigBlack.

    I’m having the same problem, I’ve checked on Android and on a laptop running windows 10, firefox and chrome browsers. It just says “please wait…the application is loading”
    This has been an issue since the update to WordPress 5.4
    Help! I’ve got this running on a site that *just* launched two weeks ago, and to have something go wrong this quickly looks horrible to the client!

    I changed, I use an online flip free generator and linked to it. Less plugin, more fast, enough options for configuration.

    @bigblack I’d love to not have to change, I’ve got this one all built into a ton of pages using custom fields and because the site just launched, I really can’t go back to the client for more money to fix something that’s gone wrong this quickly. @iberezansky I should correct myself, I am running WordPress 5.4.1 now. It’s not working at all on this. Please see http://britanniaproperties.com/1585-britannia-road-east/unit-d1/ (towards the bottom of the page – every one of their vacancies is set up like this)

    Plugin Author iberezansky

    (@iberezansky)

    @dreamkatch
    CORS problem:

    Access to XMLHttpRequest at ‘http://britannia.britanniaquote.com/wp-content/uploads/2020/02/1565_Britannia_Unit_44-45_Brochure.pdf’ from origin ‘http://britanniaproperties.com’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.

    Different domains:
    http://britanniaproperties.com/1565-britannia-road-east/unit-44-45/

    add into your .htaccess:
    # CORS for PDFs
    <IfModule mod_headers.c>
    <Files ~ “.*\.pdf$”>
    Header add Access-Control-Allow-Origin “*”
    Header add Access-Control-Allow-Methods “GET”
    Header add Access-Control-Allow-Headers: “Range”
    Header add Access-Control-Expose-Headers: “Accept-Ranges, Content-Encoding, Content-Length, Content-Range”
    </Files>
    </IfModule>

    dreamkatch

    (@dreamkatch)

    @iberezansky omg thank you! Of COURSE that’s what’s wrong, I didn’t even think of it because the update happened right after I went live, which meant updating the domain. THANK YOU! Upgrading now!

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.