Support » Plugin: WooCommerce PDF Invoices & Packing Slips » PDF Invoices sending out too fast

  • Resolved printplaygames

    (@printplaygames)


    I know this is rarely an issue, but I think the pdf invoices are sending out too fast for me. We have uploads that are attached to the order, and included in the data is a link for the file uploads. However, when the email sends, that data is not there. But if I regenerate the invoice, the data shows up. Can I get the “new customer email” to delay sending by like 60 seconds?

Viewing 1 replies (of 1 total)
  • Plugin Author Ewout

    (@pomegranate)

    It is not our plugin that sends out the email, we merely attach the PDF to the email that WooCommerce sends out (/when it does), so this is a bit out of scope.
    You could defer all the transactional emails that WooCommerce sends (not by a standard offset but simply to a separate process) with a filter:

    
    add_filter( 'woocommerce_defer_transactional_emails', '__return_true' );
    

    This was actually the default in WooCommerce for some time (because it’s a fantastic speed improvement in your checkout and various other places on your site that trigger emails), but due to issues with some specific email setups they disabled it again. I recommend running a few tests to see if this works for your setup, but if it does it’s probably the easiest and best solution here.
    I don’t know of any existing plugins/solutions that delay WooCommerce email creation for a specific time. You could also see what your options are to fix this on the other end of the process, by trying to increase priority on the linke generation.

    Good luck!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.