Support » Plugin: Ultimate Member – User Profile, User Registration, Login & Membership Plugin » PDF and profile photo (jpg, png) when registering

  • Resolved gabrielgobie

    (@gabrielgobie)


    Hello, I work for the site https://aafa-asso.info.
    We use Ultimate Members to allow users to join our association by registering through a UM registration form. During registration, we ask, among other things, users to send a profile picture (jpg or png) and a CV in PDF format.
    The problem is that when we send these 2 files using the registration form, none of the files are visible on the profile. The profile picture does not appear and it says that the CV “has been deleted”. If we send these 2 files once our account is created (from our profile page) it works well but we need these files to be uploaded upon registration to force users to send them! Going to the “wp-content / uploads / ultimatemember” folder, I noticed something strange. The normal structure in each user’s folders seems to me to be: “profile_photo190x190.jpg” (same for other sizes, 180×180, 40×40 and 80x870px) and my pdf file “file_aabbcc1234.pdf”.
    On my site, when a user registers and sends his profile picture and his CV the structure looks like this: a single jpg file “profile_e63d027a_photo.jpg” and 5 pdf files named “profile_photo.pdf”, “profile_photo-80×113 .pdf “,” profile_photo-40×57.pdf “,” profile_photo-281×398.pdf “,” profile_photo-190×269.pdf “.
    I have the impression that ittimate member considers the pdf file as the profile picture and that could explain this bug.
    What can I do to force users to send profile photos and CVs upon registration and then display them directly on the profile once the account has been validated? thanks in advance

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @gabrielgobie

    Are you using any custom code that adds the Profile Photo uploader in the Register form? If so, could you please try removing it and see if the PDF file uploader works?

    Regards,

    Thread Starter gabrielgobie

    (@gabrielgobie)

    Hi @champsupertramp , no I didn’t have a custom code. On the other hand, I had installed the plugin “Ultimate Member – Enable Profile Photo in Register form”. By disabling this github plugin (https://github.com/ultimatemember/Extended/tree/main/um-profile-photo) sending pdf during registration works. Once the user account is validated, the CV pdf is displayed on the profile page. It’s a first success! Now I would like to understand why sending a profile picture during registration does not work. The image is only displayed when I re-upload my photo from my profile page once my account is validated.
    I looked at the file in FTP and when i send the CV (PDF) and the profile photo from the registration, the photo is named “stream_photo_xxx123xxx … .jpg”.
    If I send the photo once the account is validated through the profile page, the file in the folder is correctly name “profile_photo-281×281.jpg”, “profile_photo-40×40.jpg” etc.
    Do you have a new idea to solve this problem?
    Thank you in advance !

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @gabrielgobie

    I just tested and the Profile Photo is uploading via UM Register form.

    Could you please try downloading the um-profile-photo plugin again from the Github repository and install/replace the existing one on your site?

    Regards,

    Thread Starter gabrielgobie

    (@gabrielgobie)

    Hi @champsupertramp thank you for your answer.
    Unfortunately it does not work. I did reinstall the plugin “Ultimate Member – Enable Profile Photo in Register form” but as soon as I activate the plugin sending pdf AND photos during registration no works. Once the account is validated there will not be the photo and the PDF will be marked as “deleted” from the PROFILE page.
    If I deactivate the plugin, the PDF sending works at the time of registration (the pdf is clearly visible on the profile page) but the photo still does not work.
    I took 2 screenshots to explain it better, we can clearly see the structure of the files (image and pdf) in the FTP folder of each user.
    When the plugin is active : https://aafa-asso.info/wp-content/uploads/2021/06/plugin-active.jpg
    When the plugin is desactive : https://aafa-asso.info/wp-content/uploads/2021/06/plugin-desactive.jpg
    Thank you in advance for your help.`

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @gabrielgobie

    Could you please try downloading the plugin again? I’ve made changes to the um-profile-photo plugin.

    Regards,

    Thread Starter gabrielgobie

    (@gabrielgobie)

    Hi @champsupertramp, thank you, thank you, thank you (and 1000 thank you)! It works wonderfully!

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @gabrielgobie

    Thanks for letting us know. I’m marking this as resolved now.

    Regards,

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.