WordPress.org

Support

Support » Plugins and Hacks » [Resolved] PCLZIP_ERR_BAD_FORMAT

[Resolved] PCLZIP_ERR_BAD_FORMAT

  • Hello,

    I have just tried to install the latest version of the JetPack Plugin, 1.9.1, however, when I try it, I get this error:

    “An error occurred while updating Jetpack by WordPress.com: The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature.”

    Does this mean anything to anyone?

    Thanks

    Gary

    http://wordpress.org/extend/plugins/jetpack/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Jeff Bowen

    @jblz

    Hi, Gary.

    This message means that the Jetpack software could not be extracted from the zip archive. Can you please check that your web server has available space on the volume where WordPress is installed and that you’re not running into quota issues (if applicable)?

    Thanks,
    Jeff

    Hello,

    I have been able to resolve this issue, it was exactly as you suggested. Thank you very much for taking the time to reply!

    Thanks

    Gary

    May I ask how you solved this issue? I’m currently experiencing it as well, but with all my plugins! 🙁

    Hello,

    The issue that I had was exactly as described here.

    I didn’t have any hard drive space left of my Web Server, which meant that there was no way of extracting the contents of the zip file.

    I cleared out some space, and everything started working.

    Gary

    @foodobyte

    “your web server has available space”

    In other words how much hard drive space is available for use on your hosting solution – it’s usually seen in CPanel – if not or using another admin, ask your hosting provider.

    quota issues

    Refers to the available resources allocated to your domain by your hosting provider, including total memory available (not php memory), CPU (not likely the cause of this problem) and so on.

    If you have a disk or resource issue, you need to contact your host to get it increased

    See http://core.trac.wordpress.org/ticket/22913
    There is a fix that is aimed for WP 3.6, and the fix works for me where I was having errors with simplepress upgrades.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] PCLZIP_ERR_BAD_FORMAT’ is closed to new replies.