Support » Plugin: WooCommerce PayPal Powered by Braintree Payment Gateway » PayPal with Braintree issues since update

Viewing 7 replies - 16 through 22 (of 22 total)
  • Plugin Support nixiack8

    (@nixiack8)

    Hi Andrej,

    @mrbrettkarl had a great response – Did you check the Merchant Account ID in WooCommerce to make sure it was in sync with the Merchant Account ID inside the Braintree Paypal site under Account Info? If it is not, it will give this particular error on Sandbox mode. Let us know what you find!

    Having the same issue as well. But already in production mode not sandbox mode.

    Plugin Support nixiack8

    (@nixiack8)

    Hi @dancreates,

    Please make sure your PayPal account is linked with Braintree and you have enabled it in Braintree settings. Follow https://articles.braintreepayments.com/guides/payment-methods/paypal/setup-guide

    Otherwise please attempt to disable all plugins except for WooCommerce and Braintree, and switch to the default Twenty Seventeen or Storefront theme. If the problem goes away, enable them one by one to identify the source of the problem. Let us know your steps and results!

    @nixiack8:

    Thanks for your reply.

    My issue can be solved by simply downgrading 2.0.4. I do not need to touch any of the settings, it just works. However, I would like to stay in sync with the recent releases, so sticking with 2.0.4 forever will just not work.

    Best Regards,
    Andrej

    Rich

    (@pttalkcom)

    Braintree (Credit Card) works, Braintree (PayPal) doesn’t.

    I’m getting the red “Currently unavailable. Please try a different payment method.” error.

    Here’s what I’ve got:

    On the Braintree side:
    – Braintree sandbox which I log into with a paypal account
    – Braintree Merchant Account ID in AUD (Australian dollars)
    – PayPal is enabled (green) on the Settings – Processing Options page
    – I don’t yet have a Braintree Production Account. I can’t see that I’d need one for Sandbox testing.

    On the WooCommerce side:

    WC version: 3.3.5
    WP version: 4.9.5
    PHP version: 5.6.30
    MySQL version: 5.6.32
    WC database version: 3.3.5
    WooCommerce PayPal Powered by Braintree Gateway by WooCommerce – 2.1.1
    WooCommerce by Automattic – 3.3.5

    PayPal Standard is working in Sandbox, but is currently disabled.

    I’ve disabled all plugins except WooCommerce & WooCommerce PayPal Powered by Braintree Gateway.

    In Settings – Braintree (PayPal):
    – Transaction Type: Charge
    – Environment: Sandbox
    – Sandbox Merchant ID, public and private key entered (same as Credit Card)
    – Tested both Merchant Account ID (AUD) using the default, and another one I set up in Braintree, both in AUD.
    – The following make no difference whether enabled or not: Enable Cart Checkout, Tokenization, Detailed Decline Messages, Dynamic Descriptors-Name

    Any ideas?

    Thanks!

    Ok, PEBKAC. Sorry!

    Once I set up the link between the PayPal Sandbox and the Braintree Sandbox the problem was resolved. Here are the steps I was missing:

    https://developers.braintreepayments.com/guides/paypal/testing-go-live/php#linked-paypal-testing

    Hey there I had the same problem. By default, we use the Braintree Mock sandbox flow for testing transactions on our Magento install.

    Unfortunately it seems using the Mock PayPal flow causes the “Currently unavailable. Please try a different payment method.” message.

    Make sure you link your Braintree and PayPal sandboxes then test. Everything worked a treat for me after that.

Viewing 7 replies - 16 through 22 (of 22 total)
  • You must be logged in to reply to this topic.