Support » Plugin: PayPal for WooCommerce » PayPal Pro 2.0 PayFlow

  • Resolved pbtazit

    (@pbtazit)


    This Option for PayPal Pro 2.0 PAYFLOW :

    [ User (optional) If you set up one or more additional users on the account, this value is the ID of the user authorized to process transactions. Otherwise, leave this field blank.]

    It will NOT SAVE in an EMPTY or BLank state, it always populates with the Merchant ID no matter how many times I try to save this option as blank.

    Believe it is causing me to get a {Payment error: 26-Invalid vendor account}

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author angelleye

    (@angelleye)

    @pbtazit, Sorry for the confusion. The PayPal PayFlow API actually does require all 4 fields to be filled in, and if you don’t create a specific user account, then the user value is supposed to be the same as the merchant value.

    In the plugin code, if the user value is empty it automatically inserts the merchant value, which is why we had the message about leaving it blank. It seems at some point we started auto-filling the value upon saving settings, so now that message about leaving it blank is definitely confusing!

    We’ll adjust that message so it’s more clear, but you don’t need to worry about anything. It should be saving with the merchant value as you said, and that needs to happen for the API request anyway, so it should be fine.

    pbtazit

    (@pbtazit)

    Just updated Your Plugin now ADD TO CART is MISSING ??????????????????????????????????????????????????????????????????????????

    How do I restore to last version???????????????????

    Plugin Author angelleye

    (@angelleye)

    @pbtazit, That’s odd. We don’t have any other reports of that happening. Do you remember which version you updated from?

    All previous versions of the plugin are available in the advanced section of the plugin page on WordPress. Scroll down to Previous Versions and you can choose any version you want. Then you would just need to update manually on the site.

    After updating, make sure you cleared any caching / CDN tools that could be conflicting.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.