Support » Plugin: PayPal Plus for WooCommerce » Paypal Plus Bezahlvorgang klappt nicht

  • Resolved muuclemens

    (@muuclemens)



    Hallo:
    ich habe nach einigen Anfangsproblemen den Bezahlvorgang mit Paypal Plus im Sandbox Modus zum Laufen gebracht. Zwischenzeitlich habe ich diverse Tests gemacht und wollte nun heute unseren Shop Live schalten.

    Das Problem: Mit den Live Zugangsdaten für die API wird mit die erste Check Out seite angezeigt. Ich kann die Bezahlart wählen. Aber dann geht es nicht mehr weiter: Es fehlt der Button “zum nächsten Schritt”.

    Nun bin ich wieder zurück in den Sandbox Modus und auch hier fehlt der Button. Wenn ich Paypal Plus deaktiviere geht alles. Ich habe wiederum nahezu alle Plugins schrittweise deaktiviert konnte aber bisher keinen Weg finden, den Button wieder erscheinen zu lassen.

    Ich habe die PHP Versionen 7.0 7.1 und 7.2. getestet ohne erfolg.

    Hier ein Fehler Log Seitens Woocommerce:
    #6 /home/wp/disk/wo in /home/wp/disk/wordpress/wp-content/plugins/woo-paypalplus/src/WC/PayPalPlusGateway.php on line 517
    #5 /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/wc-core-functions.php(210): include(‘/home/wp/disk/w…’)
    #4 /home/wp/disk/wordpress/wp-content/plugins/woocommerce/templates/checkout/payment.php(30): wc_get_template(‘checkout/paymen…’, Array)
    #3 /home/wp/disk/wordpress/wp-content/plugins/woocommerce/includes/wc-core-functions.php(210): include(‘/home/wp/disk/w…’)
    #2 /home/wp/disk/wordpress/wp-content/plugins/woocommerce/templates/checkout/payment-method.php(31): WCPayPalPlus\WC\PayPalPlusGateway->payment_fields()
    #1 /home/wp/disk/wordpress/wp-content/plugins/woo-paypalplus/src/WC/PayPalPlusGateway.php(481): WCPayPalPlus\WC\PayPalPlusGateway->form()
    #0 /home/wp/disk/wordpress/wp-content/plugins/woo-paypalplus/src/WC/PayPalPlusGateway.php(494): WCPayPalPlus\WC\PayPalPlusGateway->get_approval_url()
    Stack trace:
    [27-Aug-2018 12:04:11 UTC] PHP Fatal error: Uncaught Error: Call to a member function getApprovalLink() on null in /home/wp/disk/wordpress/wp-content/plugins/woo-paypalplus/src/WC/PayPalPlusGateway.php:517
    [27-Aug-2018 12:04:10 UTC] PHP Warning: php_uname() has been disabled for security reasons in /home/wp/disk/wordpress/wp-content/plugins/woo-paypalplus/lib/PayPal/Common/PayPalUserAgent.php on line 28
    [27-Aug-2018 12:04:10 UTC] PHP Warning: php_uname() has been disabled for security reasons in /home/wp/disk/wordpress/wp-content/plugins/woo-paypalplus/lib/PayPal/Common/PayPalUserAgent.php on line 27

    Was ist zu tun?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Andreas W.

    (@aweissinpsyde)

    Hallo @muuclemens,

    benutzt du ein Cache Plugin, welches JS Files chached? Ist das Verhalten auch mit dem WordPress Standard Theme sichtbar. Testweise einfach mal das Thema wechseln.

    Kannst du mir bitte den Link zur Webseite mitteilen?

    Vielen Dank

    Hi: ich arbeite mit dem enfold Theme, das eine Art eingebauten Cache hat. Da die Seite auf einem NGINX server gehostet ist verwende ich allerdings das Enfold Caching nicht. Die Cache einstellungen des Servers kann ich nicht beeinflussen

    Ansonsten habe ich jetzt ein anderes Plugin genommen – die Seite musste live gehen. Dennoch wäre ich an paypal plus interessiert da im Nachhinein die verwaltung der Vorgänge einfacher wäre

    Plugin Author Andreas W.

    (@aweissinpsyde)

    Hallo @muuclemens

    wÄre es denkbar eine Kopie diese Seite für Testzwekce zu erstellen, wo wir PayPal PLus mit deinem Themen testen könnten?

    Mit besten Dank

    Du meinst eine Kopie lokal bei Euch?

    Plugin Author Andreas W.

    (@aweissinpsyde)

    Halo @muuclemens,

    bei dir. Z.b. auf einer Subdomain, sodass wir den Fehler dort reporduzieren und berichtigen können. Wenn alles wie gewünscht funktioniert, werden die Einstellungen auf die Liveseite übertragen.

    das muss ich erst mal prüfen. Ich habe ein Paket das gilt für eine Domain. Subdomains sind da nicht vorgesehen

    Plugin Author Andreas W.

    (@aweissinpsyde)

    Hallo @muuclemens

    ok, bitte prüfe das einmal.

    Vielen Dank

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.