Support » Plugin: WooCommerce » Paypal order status "Unclaimed". Woocommerce order status "On Hold"

  • Resolved jeffm2008

    (@jeffm2008)


    I’ve recently set up PayPal Standard in woocommerce and all of my orders say “On Hold” with the error note: “Payment pending: address Order status changed from Pending Payment to On Hold.”

    Also, all of my PayPal orders say “Unclaimed”.

    I’ve been checking online for solutions and believe I have my settings correct.

    Any help would be extremely appreciated.

    Thank you in advance!

    https://wordpress.org/plugins/woocommerce/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Check the email address that you have set in woocommerce for paypal payments to be sent to.

    Login to your paypal account and see what the status of the payments are.

    There are settings in woocommerce which you have to adjust to autocomplete orders.
    Go to wp admin – woocommerce – settings and check that the setting “orders to auto complete” is set to “all orders”.

    Thank you for your response.

    It does appear that my email address in woocommerce is set to my verified primary PayPal email address.

    Also, unfortunately I do not see a setting in the woocommere settings for “orders to autocomplete”. Could you please tell me exactly where that is located?

    The only thing that I see that is close is “Payment Action” is set to “capture”. With the other option being “Authorize”.

    Thank you again.

    I did actually verify a new PayPal primary email address yesterday, AFTER I initially set up PayPal standard with my old email address.

    However, it is currently set to my new primary PayPal email address.

    I don’t know if it takes a while to update the new address on PayPals server?

    Hope that made sense.

    As long as an email address shows as verified in your paypal account then you should be good to go on that email address instantly.

    For the autocomplete:

    Go to wp admin – woocommerce – settings – “general” tab and check that the setting “orders to auto complete” is set to “all orders”.

    Thank you.

    I don’t seem to have the option “orders to auto complete” in WooCommerce Version 2.4.12.

    Thank you for your help.

    My apologies…

    It’s a plugin that i am using to achieve this:

    https://www.woothemes.com/products/woocommerce-order-status-control/

    Oh OK. Thanks.

    In woo commerce, that’s the only way to auto complete all of your orders.

    if your orders are not auto completing (if they are always “on hold”) remember that your customers are also not getting the order confirmation emails….until you manually update the order from “on hold” or “processing” to “complete”.

    The auto complete bypasses all of this and auto completes all orders, which results is happy customers because they instantly receive a confirmation and notification that their order placement is confirmed.

    Makes sense.

    I still feel like something is not configured properly since the woocommerce orders are always “on hold” and never “processing” and the PayPal order status is always “Unclaimed” and never “Completed”.

    Something seems wrong.

    Yep…

    Go to admin and take a look at one of the recent orders.

    To do this, see the list of orders and click on the order number for one of them.

    In the order notes on the right hand side of the order page, do you see 1 or more order notes?
    You should see status updates such as:

    Booking #77177 status changed from “in-cart” to “unpaid

    IPN payment completed

    Order status changed from Pending Payment to Completed.

    Booking #77177 status changed from “unpaid” to “paid

    The important one here is the “IPN payment completed”

    Do you see this one?

    Or are there other order notes which are not listed above?

    If you can paste the order note texts here it might help to find the issue.

    But you should also take a good look at your paypal account and the settings for paypal in woocommerce too.

    This is the only order note I get “Payment pending: address Order status changed from Pending Payment to On Hold.”

    Unless I go into PayPal and manually accept the “Unclaimed” order. Then the order notes “IPN payment completed” and “Order status changed from On Hold to Processing” appear.

    Just found this which may help….

    In your paypal account, go to “Profile”
    Select “Profile and settings”
    Select “My selling tools”
    Under “Getting paid and managing my risk” select “Update” for “Block payments”

    Allow payments sent to me in a currency I do not hold: = Yes, accept and convert into xxx

    Block accidental payments: = No, Allow….

    Select “Save”

    This may solve the issue of you needing to “authorise” each payment you receive.

    Let me know what happens.

    Geez. Not sure who you are, or why you are so helpful. but, you fixed it!

    Thank you very much!

    It was actually the setting “For the items not sold on eBay, Only allow payments from the users with confirmed address.” I set it to “No”.

    That made it work. The PayPal order status is “Completed” and my Woocommerce order status is “Processing”. Perfect!

    Thanks again.

    That’s excellent news!
    Glad i could help.

    I’m just another woocommerce / paypal user. I saw your issue posted and was interested in helping to solve it….i like to solve problems 🙂 Keeps the mind fresh!

    Good luck with your venture.

    Thanks again, you too!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Paypal order status "Unclaimed". Woocommerce order status "On Hold"’ is closed to new replies.