Support » Plugin: WooCommerce PayPal Powered by Braintree Payment Gateway » PayPal option not generating a nonce

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor woosteve

    (@woosteve)

    Automattic Happiness Engineer

    Hey alipally,

    I’ll be happy to help you get this sorted out.

    Can you temporarily switch to a default theme and disable all other plugins and run a test to see if it now works properly? If it does, please enable one feature at a time until you can determine which is causing the issue.

    Let me know how it goes.

    Plugin Contributor allendav

    (@allendav)

    Hi alipally!

    We think we have identified the bug. If a store owner connects to PayPal Powered by Braintree, but doesn’t make any changes to the settings for the plugin, the gateway will appear to be enabled when it is not fully enabled.

    Please proceed to wp-admin > WooCommerce > Settings > Checkout > PayPal Powered by Braintree and hit the Save Changes button (it is not necessary to make any changes) as a workaround. After doing that, checkouts should work correctly.

    We are working on an updated version of the plugin that corrects this bug.

    Hello everyone.

    I’ve run into a problem with the Braintree Powered by Paypal plugin.

    I went from sandbox -> production. When I did the plugin (as an element for checkout) did not activate. The enable button is checked on.

    Also, it seemed to skip steps when resetting and went directly to the end.

    Any help would be appreciated.

    I have pictures too, if it helps.

    Plugin Contributor Andrew

    (@slash1andy)

    Automattic Happiness Engineer

    Hey there johnpapazian,

    Please create your own topic here, as this one has been solved for about a month now 🙂

    thanks slash1andy. created new topic. hope you can help.
    called — WooCommerce PayPal Powered by Braintree Payment Gateway

    Hi, I’m having this issue with my site as well (https://farmersdiet.co) – We launched yesterday and had a lot of people complain about being unable to put cc info into the field and got a “BRAINTREE DID NOT SUPPLY A PAYMENT NONCE”.

    Is there a permanent fix to this yet? Thanks!

    beckyjmonroehotmail.com

    (@beckyjmonroehotmailcom)

    I am having issues with this as well. I have the enable box checked, but on the checkout settings page (the summary page) — it does not show as enabled. I have gone out and in and tried to disconnect and reconnect braintree and i cam’t make it work!

    beckyjmonroehotmail.com

    (@beckyjmonroehotmailcom)

    Here’s the link to the site

    Matt

    (@bullymaxinc)

    Hi @woosteve & @allendav

    This error is still occurring on the latest version of the plugin.

    It isn’t a plugin or theme conflict. I’ve tested this on multiple themes, and disabled & enabled all plugins one by one.

    I also tried the work around ( wp-admin > WooCommerce > Settings > Checkout > PayPal Powered by Braintree and hit the Save Changes button) — however this didn’t solve the issue.

    I’m still seeing multiple users who are getting this error message (http://imgur.com/a/Nh40l) – “Error: PayPal Powered by Braintree did not supply a payment nonce. Please try again later or use another means of payment.”

    Any suggestions on a solution for this issue?

    Thanks in advance and have a great day

    Matthew Kinneman
    https://Bullymax.com
    Matt@bullymax.com

    • This reply was modified 1 year, 6 months ago by  Matt.
    Plugin Contributor woosteve

    (@woosteve)

    Automattic Happiness Engineer

    Hi Matt,

    Can you confirm that you are running version 1.2.4 of the WooCommerce PayPal Powered by Braintree Gateway?

    Since this thread has already been marked as resolved, I would also ask that you either open a new thread or submit a ticket directly through our site so we can investigate further.

    Thanks for your understanding.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘PayPal option not generating a nonce’ is closed to new replies.