Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » PayPal NOT working “Sorry Error”

  • Resolved sbclions

    (@sbclions)


    Hello,

    I am trying to assist a charity, Lions Club. their site is at sbclions.com

    They were able to receive donations fine until July. They are in desperate need right now due to the Typhoons. They have willing and waiting donors that keep getting error messages.

    Please try yourself on the site at https://sbclions.com and do a test. Once you click DONATE then it goes to a PayPal error page.

    I have updated the entire site except for the 2x “Elementor” plugins which i do NOT want to update.

    I have been trouble shooting for over 4 hours now and the only thing I am unable to complete or think MAY be the cause is the “GiveWP” Plugin will not update.

    When I try to update it either quits on error or just “hangs”. I have tried the instructions here https://givewp.com/documentation/core/frequent-troubleshooting-issues/handling-database-update-issues/ but the issue still remains, Donors cannot donate and the people are in desperate need right now for food, water and shelter due to all the Typhoon flooding.

    They are a Charity and 100% volunteer and 100% off their donations (plus out of their pockets) goes to helping the needy & poor I am Begging for help.

    HOSTING CO PROVIDED THIS:

    you can check the error logs from file manager http://prntscr.com/vkkhwt

    [17-Nov-2020 07:44:06 UTC] WordPress database error Table ‘sbc81lio_wp622.wp_give_revenue’ doesn’t exist for query INSERT INTO wp_give_revenue (donation_id, form_id, amount) VALUES (2409, 1852, 2500) made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘init’), WP_Hook->do_action, WP_Hook->apply_filters, give_post_actions, do_action(‘give_purchase’), WP_Hook->do_action, WP_Hook->apply_filters, give_process_donation_form, give_send_to_gateway, do_action(‘give_gateway_paypal’), WP_Hook->do_action, WP_Hook->apply_filters, give_process_paypal_payment, give_create_payment, give_insert_payment, do_action(‘give_insert_payment’), WP_Hook->do_action, WP_Hook->apply_filters, Give\Helpers\Hooks::Give\Helpers{closure}, call_user_func_array, Give\Revenue\DonationHandler->handle, Give\Revenue\Repositories\Revenue->insert

    Ben Meredith (@benmeredithgmailcom)

    Thanks for the reply on the other now “closed thread” but that was a similar issue however, not the same. I replied to your email. I tried that and still not working. I included screenshot and more info

    Thanks, there are so many that need help and we HAVE donors to help but unable to process through PP 🙁

    Running PHP 7.4, Latest WP Core

    Can you or anyone assist me?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Ben Meredith

    (@benmeredithgmailcom)

    Hi there,

    We are assisting with this via email. Rick last replied less than 2 hours ago. We’re working through as many tickets as we can, and opening new ones here only slows us down.

    Please continue the conversation via email. Thanks!

    Hi @benmeredithgmailcom,

    I got the same error with OP. Any recommendation on the said issue? I cannot proceed with the GiveWP upgrade DB. I already deactivated my security plugins and DB caching.

    WordPress database error Table ‘db4622339226.wp_give_revenue’ doesn’t exist for query
    SELECT donation_id
    FROM wp_give_revenue
    WHERE donation_id = 1960
    made by do_action(‘wp_ajax_wp_give_db_updater’), WP_Hook->do_action, WP_Hook->apply_filters, Give_Background_Updater->maybe_handle, Give_Background_Updater->handle, Give_Background_Updater->task, Give\Revenue\Migrations\AddPastDonationsToRevenueTable->run, Give\Revenue\Repositories\Revenue->isDonationExist

    Appreciate your feedback on this matter.

    ________________________________________________

    I cannot proceed also with the paypal donation: https://nohfh.com/donate/

    Plugin Contributor Ben Meredith

    (@benmeredithgmailcom)

    Hi there,

    The error you are getting is related to a database routine not working as expected when your site updated to 2.9.0.

    Here’s the slightly technical long version: GiveWP version 2.9.0 adds a new revenue table to your site’s database. Going forward, this revenue table will make sites much more performant for things like reporting on how many donations have come in, and how much revenue has been created.

    The database routine that adds a table should have automatically happened silently in the background immediately following the update. In your site’s case, it did not. We’ve since discovered that the reason is didn’t happen is that our DB routine was not backward compatible for older versions of SQL engines.

    This does not affect donations coming in at all.

    Your ticket and others have helped us to realize that (even though donations are not affected) some processes relying on that revenue table still can fail, which is what is happening here.

    I’ve logged your feedback so that our Product Development team can see it. You can provide additional details or track the progress of the feedback here: https://feedback.givewp.com/bug-reports/p/deleting-donations-without-a-revenue-table-should-not-cause-a-fatal-error

    So that’s the problem. Here’s the solution:

    To resolve this, you need to manually create that database table.

    Here are the steps:

    1. Log into your site.
    2. Go to the following URLs, in order: (add your base URL to each)
    /wp-admin/?give-run-migration=create_revenue_table (this manually forces the database routine again)
    /wp-admin/?give-run-migration=add-past-donation-data-to-revenue-table (this manually adds existing donations to the revenue table)
    /wp-admin/edit.php?post_type=give_forms&page=give-tools&tab=logs&section=updates (this checks the logs to see if there were any errors.
    3. If there are no errors showing in the log on that last URL, you should be good to go.

    Hi @benmeredithgmailcom

    Thank you so much for your reply.
    First URL was successfully added to DB.
    2nd URL have an error adding to DB https://prnt.sc/vmw0pt
    3rd URL screenshot https://prnt.sc/vmw40y

    I tried to update GiveWP but still I am not getting any progress https://prnt.sc/vmw711

    Regards,

    Plugin Contributor Ben Meredith

    (@benmeredithgmailcom)

    Hi folks, that second url should be

    wp-admin/?give-clear-update=add-past-donation-data-to-revenue-table

    Which will then populate a dialog to re-start that routine.

    Thanks!

    @benmeredithgmailcom

    Thank you for taking action on this.
    This is the result of the URL: https://prnt.sc/voisj3

    I am not getting any results from the “Run the Updater”
    https://prnt.sc/voir51

    Any recommendations? Thanks.

    Regards,

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.