Support » Plugin: WooCommerce » Paypal IPNs failing

Viewing 9 replies - 1 through 9 (of 9 total)
  • same thing worked fine before the update..now it bombs out going to:
    http://www.njproghouse.com/wc-api/WC_Gateway_Paypal/

    I reverted to the previous version(2.1.7). It still appears to be happening. The client reports that orders are not marked as paid, even though PP shows that the money came in.

    Same thing with me. On May 14, it worked in the morning before the update, I did the update in the afternoon, few hours later, with a new order, the order is considered as canceled by WC. I only receive a mail from Paypal that a payment has been done, I don’t receive the notification e-mail from WC.
    I have activated the logging feature for Paypal IPN in the WC Admin Setting panel and I will see what is happening.
    Something is broken with Paypal IPN. I don’t exactly use Paypal IPN but a PayPal Identity Token.
    Should I revert to a regular Paypal IPN ?

    Since yesterday, it is now working. I have done nothing on WC or Paypal, no new update.

    We only saw one order yesterday, but it worked correctly also.

    Will be keeping an eye on it.

    yeah things were working fine for a few weeks… now failing..

    anyone have any suggestions?

    I have found a solution. I got orders with a status “canceled” after PayPal payment done.
    After activating the logs for Paypal in Woocommerce, I saw that in fact Woocommerce used a time out to cancel an order, waiting for the Paypal IPN. Sometimes, instead of taking 1 min., Paypal can take, say, 20 min. to send its IPN check. Thus Woocommerce changed the status from “pending” to “canceled”. The good news is we can change the time out. The trick is to find where. The solution is to be found in the inventory settings.

    First, check if it is an issue with the PayPal IPN not being received and the order status being set to pending. You can check by going to WooCommerce > System Status > WP Remote Post and confirm that it is working.
    Second, to disable automatic cancellation of pending orders, go to WooCommerce > Settings > Inventory and set Hold Stock (minutes) to 0 or to a longer time (60 min, 240 min., …).

    @pozhonks, thanks for that.

    I’m not seeing an Inventory setting. Perhaps that’s part of an extension that you’ve added?

    Fortunately, I haven’t heard any more complaints about PP cancelling orders lately either.

    Hey folks,

    Recently I also get into the same issue mentioned here and find the solution also later.

    Please check link for the solution which helped me also – http://www.jeriffcheng.com/unpaid-order-cancelled-time-limit-reached.html

    Update me if it helps to you too..!

    Cheers,

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Paypal IPNs failing’ is closed to new replies.