Support » Plugin: Event Espresso 4 Decaf - Event Registration Event Ticketing » PayPal IPN issue with Registration Payments on Event Espresso 4.9.65.decaf

  • Hello, and thanks for such a helpful plugin!

    We have our PayPal API settings all filled in, including password, signature etc.

    We’re using Event Registration payments via PayPal. We are getting error emails from PayPal that read as follows:

    Please check your server that handles PayPal Instant Payment Notifications (IPN). IPNs sent to the following URL(s) are failing:

    http://www.azusastreetriders.com/api/gateway/callback/paypal/

    If you do not recognize this URL, you may be using a service provider that is using IPN on your behalf. Please contact your service provider with the above information. If this problem continues, IPNs may be disabled for your account.

    Thank you for your prompt attention to this issue.

    Thanks,

    PayPal

    having scoured the web for help on this, we are not using any of the known culprit plugins you folks mentioned in one of your help forum posts (i.e. security plugins, redirection plugins, etc).

    The page in question is not “inputted” by us at PayPal or on our WordPress site, so I’m thinking it must be coming from the Event Espresso plugin’s code.

    http://www.azusastreetriders.com/api/gateway/callback/paypal/

    We have no other PayPal activity on this site (one site in a multisite), and we have no other PayPal related plugins on this site.

    Can anyone give us any tips or help?

    PayPal is warning IPN may deactivated if we don’t get this fixed.

    Thank you!

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Josh Feck

    (@builtbynorthby)

    Hi,

    You can actually disable the IPN setting in your PayPal account, because the PayPal Express gateway does not use IPNs.

    To disable the IPN setting, you follow these steps:
    1) Log in to your PayPal.com account.
    2) Look for Profile (gear icon) on the top of your screen and click on it. Then click on Profile and Settings.
    3) Click on My selling tools. Then click on the Update link for Instant Payment Notifications.
    4) The next screen will include an option to disable the IPN, here’s what my PayPal account settings for IPN look like:
    https://slack-files.com/T02SY781D-FC00RB2V8-2c8f02041f

    Thanks. Our setup is a tad bit complicated. We have this plugin on the main site (of a multisite). No other payment plugins are present on the main site. We have a sub site (using subfolder structure, not sub-domain structure) that is a store site using WooCommerce, and I have IPN enabled on that site due to having read about use of IPN with WooCommerce.

    We’re getting IPN error notices on event registrations on the main site, and yet disabling IPN on PayPal would presumably impact the sub site, potentially detrimentally.

    I sure am open to advise and I appreciate the time you already took to respond.

    For what it’s worth, I think our WooCommerce setup is also using PayPal Express – although I cannot remember for certain if it is using PayPal Express *exclusively*.

    Plugin Author sethshoultes

    (@sethshoultes)

    Just wanted to point out that the URL you shared is broken (page can’t be found/404):
    https://azusastreetriders.com/api/gateway/callback/paypal/

    Screenshot: https://www.screencast.com/t/48RPh4tMa

    Dear Seth:

    As I said in my original post:

    The page in question is not “inputted” by us at PayPal or on our WordPress site, so I’m thinking it must be coming from the Event Espresso plugin’s code.

    The fact that page cannot be found, is not anything I can fix by editing a URL I did not create (anywhere, either on PayPal or in our site), nor is it something I can fix by simply creating a page. The page would need to have special functions/code for corresponding with PayPal’s IPN messages.

    One part of this I thought would be more obvious, but perhaps needs to be asked straight out, is:

    Is there somewhere inside the Event Espresso 4 plugin where the user has control over IPN (on or off) or over the URL for IPN if it cannot be turned off in the plugin?

    That’s really what I was driving at when I mentioned the IPN messages are being sent to a page at a URL we did not input anywhere.

    I hope that helps someone help us! LOL.

    Thanks for being so kind and thanks again for such a great plugin.

    Also, to add more info for better clarity:

    Where in our PayPal setup we have IPN enabled, the URL we have entered there is *not* the above URL that is throwing errors whenever a site user pays for an event registration via this plugin.

    Plugin Author sethshoultes

    (@sethshoultes)

    Is there somewhere inside the Event Espresso 4 plugin where the user has control over IPN (on or off) or over the URL for IPN if it cannot be turned off in the plugin?

    No.

    I followed up with a developer on this and they mentioned we don’t listen for any callback from PayPal when using PayPal Express.

    Thanks!

    I’m at a loss for where PayPal is conjuring that URL from. Maybe it’s some kind of default URL they look to, based on the vendor’s domain.

    I appreciate the help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘PayPal IPN issue with Registration Payments on Event Espresso 4.9.65.decaf’ is closed to new replies.