Support » Plugin: StageShow » PayPal Interrface issues

  • Resolved cohenja

    (@cohenja)


    I am having difficulty setting up my PayPal – Stageshow interface correctly. Let me start by saying that we can accept donations with no problem on our site (buffalosilverband.org) through Paypal. When I purchase a ticket through Stage Show, I get switched as usual to PayPal and ask for a credit card transaction. If I had selected “Block Non-Encrypted Website” in Web preferences, I get the following error message from PayPal: “The seller accepts encrypted website payments only. You cannot pay the seller through un-encrypted buttons. Please contact your seller for more details” , and the transaction is not completed.
    If on the other hand, I had allowed for non-encrypted payments, the payment appears to be proceeding normally. I am sent to PayPal to complete the payment information, but upon switching back to my site after processing, I get a scary warning that my information is going to be going over a non-encrypted connection (but for some reason is not doing it at the moment-though it has done this).
    I have “Auto Return” set “On” in Website Preferences, with the return URL listed as https://buffalosilverband.org/payment-successful/ . The actual URL that is displayed on transfer is not encrypted: http://buffalosilverband.org/payment-successful/?amt=10.00&cc=USD&cm=48&st=Completed&tx=xxxxxx . PayPal account optional is “On”. “Block Non-encrypted Website is “Off”. The notification URL for the IPN is as you have specified in your docs, starting with htps://www.sivervband.org……
    I did this in Firefox 501.10
    I sent the following support request to PayPal:

    “In my website preferences, I have set “Auto Return” and specify an encrypted site (https://buffalosilverband.org/payment-successful/ ) for the completed transaction to return to after payment processing. Paypal appears to ignore the https:// prefix and returns to, for example, http://buffalosilverband.org/payment-successful/?amt=10.00&cc=USD&cm=47&st=Completed&tx=xxxxxxxx . I have received warning messages from my browser, although I am not getting them at the moment. I don’t want my customers to ever see a warning message when making their payment.”
    I received this from their support team:
    “Hi Joel,

    Thank you for contacting Merchant Technical Services.

    From my checking, I find that you have set the return URL on your account correctly. But, you have set the return and cancel URL when you created the button on your PayPal account which does not include the HTTPS.

    Please edit the button code and re-paste the code on your website. This issue should be resolved. Please test this and let me know.

    I hope I was able to address your inquiry to your satisfaction. If you have further questions relating to this inquiry or any other issue, please do not hesitate to let me know. Otherwise, please mark this ticket as solved.

    Thank you for choosing PayPal and have a nice day.

    Sincerely,
    Ganesh”
    But Stage Show does the interface with PayPal, not me, so how do fix this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Malcolm

    (@malcolm-oph)

    Firstly, I’m sorry for the delayed response. I was away last week and Internet access was … well, non-existent!

    The “Encrypted Website Payments” is intended for applications where the items that can be added to the PayPal shopping cart are already known, and each one can have a PayPal button defined for it. These buttons can then be stored on the PayPal server (a hosted button) and referred to using only an Id allocated by PayPal. (Really this option should be “Only Allow PayPal Hosted Buttons”). As far as I know, hosted buttons can only be created using the options on the PayPal admin pages. In the case of StageShow the items available are determined by the StageShow configuration and therefore StageShow cannot use hosted buttons, and creates button code when Checkout is clicked. For this reason the “Encrypted Website Payments” option must be set to Off. There is no loss of security if your website uses https as all the data passed to PayPal is encrypted anyway.

    If the StageShow settings include values for “Auto Return” URLs, then these are passed to PayPal on checkout, and should override the values in the PayPal settings. So if these values are http://**** rather than https://**** then you will be diverted to a non-secure URL on checkout completion. I suspect that this is where your problem lies.

    Thread Starter cohenja

    (@cohenja)

    Malcom,

    Thanks for your response. First, things seem to be working now…that is I am not getting the security message. BUT, I still don’t understand why the page I am returned to is http://buffalosilverband.org/payment-successful/?amt=12.50&cc=USD&cm=51&st=Completed&tx=xxxxx.. (Actually, that is what is pasted from a cut and paste of the address bar. The http:// is not actually displayed in the browser.) Apparently not encrypted, even though I the return address is specified as https://buffalosilverband.org/payment-successful/ … that is, encrypted.

    The PayPal support person apparently believes, and thank you for your patience with a novice in all of this, that this is being done by your code: “From my checking, I find that you have set the return URL on your account correctly. But, you have set the return and cancel URL when you created the button on your PayPal account which does not include the HTTPS.”

    So, I don’t know whether to be concerned about non-encrypted data or not. Ganesh from PayPal says to get in touch with him if you have questions. (PayPal Merchant Technical Support <support@paypal-techsupport.com> Incident: 170124-000192)

    Plugin Author Malcolm

    (@malcolm-oph)

    As I said in my first reply, the StageShow settings include the option to set “Auto Return” URLs (Checkout Complete URL and Checkout Cancelled URL) and these are passed to PayPal. The message passed to PayPal is identical to a PayPal button so that is what they have (incorrectly) assumed you have created. My guess is that you have the Checkout Complete URL and/or Checkout Cancelled URL set to http rather than https.

    • This reply was modified 5 years, 11 months ago by Malcolm.
    • This reply was modified 5 years, 11 months ago by Malcolm.
    Thread Starter cohenja

    (@cohenja)

    Thanks, Malcom. I did have these settings incorrect.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PayPal Interrface issues’ is closed to new replies.