Support » Plugin: PayPal for WooCommerce » PayPal Express Checkout Error Notification

  • Resolved iEyeBeauty

    (@ieyebeauty)


    Received this error message.

    PayPal SetExpressCheckout API call failed
    Detailed Error Message: A match of the Shipping Address City, State, and Postal Code failed.
    Short Error Message: Shipping Address Invalid City State Postal Code
    Error Code: 10736
    Error Severity Code: Error

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Contributor angelleye

    (@angelleye)

    These seem to be two different issues.

    @ieyebeauty, in your case it seems that the full address sent to PayPal simply didn’t match up with the postal service system they use to verify addresses. As the error states, the city, state, and zip code simply don’t seem to match up, so that would need to be corrected to get passed the problem.

    @ljgarnes, This issue is something we had reports of on previous versions, but per our in-house testing and some reports from other users the latest update fixed it. Can you verify you have updated to our most recent 1.4.5 version?

    For both of you, can you check to see if logging is enabled in the plugin? If so, please submit a ticket here and provide a copy of the log file so we can review it.

    PayPal SetExpressCheckout API call failed
    Detailed Error Message: The field Shipping Address1 is required
    Short Error Message: Shipping Address1 Empty
    Error Code: 10727
    Error Severity Code: Error

    Version 1.4.5

    Also I’ve sent log ticket
    I don’t have adress checkout forms cause it’s virtual products
    Had 7 errors in last 10 min

    • This reply was modified 2 years, 5 months ago by  kireaki.
    • This reply was modified 2 years, 5 months ago by  kireaki.

    This is still a thing and i have latest plugin update and every order have this error now :/

    Plugin Contributor angelleye

    (@angelleye)

    We’ve made some adjustments to the release branch on GitHub that should resolve this. Please use the link to download the zip, extract the files, and upload the files to your server manually, ensuring that you overwrite the existing plugin files.

    If you could give that a try and verify whether or not it resolves your issue that would be great. If you have any questions about applying that update let me know.

    Thanks!

    Funny thing I’ve sent ticket and said that I did installed this and i still get same error and your answer was.. install it again like really :/ then error stopped and now it’s happening again I just don’t know what to think or do anymore http://prntscr.com/flbs93

    Plugin Contributor Oliver

    (@angelleyesupport)

    @kireaki,

    That’s strange how this can work and then don’t work again…. I believe there some old cache that might be creating the conflict. Did you clear the Cache’s ( Browser and CDN and for Cache plugin’s too) multiple times to make sure there is no old cache remaining then see if you were able to produce the error again?

    Hi, yeah i cached everything with WP Rocket plugin and also cloudflare i just had 5 errors in a row :/

    And i have virtual products so there is no need for shipping adress and I don’t even have shipping checkout forms
    Version 1.4.5 | By Angell EYE

    2017-06-18T22:07:08+00:00 INFO Redirecting to PayPal
    2017-06-18T22:07:08+00:00 INFO PayPal for WooCommerce Version: 1.4.5
    2017-06-18T22:07:08+00:00 INFO WooCommerce Version: 3.0.8
    2017-06-18T22:07:08+00:00 INFO Test Mode:
    2017-06-18T22:07:08+00:00 INFO Endpoint: https://api-3t.paypal.com/nvp
    2017-06-18T22:07:08+00:00 INFO SetExpressCheckout Request: Array
    (
    [USER] => *****
    [PWD] => *****
    [VERSION] => 124.0
    [BUTTONSOURCE] => AngellEYE_SP_WooCommerce
    [SIGNATURE] => *****
    [METHOD] => SetExpressCheckout
    [RETURNURL] => https://kireaki.com/wc-api/WC_Gateway_PayPal_Express_AngellEYE/?pp_action=get_express_checkout_details
    [CANCELURL] => https://kireaki.com/
    [ALLOWNOTE] => 1
    [ADDROVERRIDE] => 1
    [LOGOIMG] => https://kireaki.com/wp-content/uploads/2017/05/KIREAKI-LOGO-STREAM-DESIGN-200X80.png
    [BRANDNAME] => Kireaki Stream Design
    [PAYMENTREQUEST_0_AMT] => 8.00
    [PAYMENTREQUEST_0_CURRENCYCODE] => EUR
    [PAYMENTREQUEST_0_PAYMENTACTION] => Sale
    [PAYMENTREQUEST_0_SHIPTONAME] => tom wagar
    [PAYMENTREQUEST_0_SHIPTOCOUNTRYCODE] => US
    [L_PAYMENTREQUEST_0_NAME0] => Light circle fields animated scenes
    [L_PAYMENTREQUEST_0_QTY0] => 1
    [L_PAYMENTREQUEST_0_AMT0] => 8
    [L_PAYMENTREQUEST_0_NUMBER0] => 24716
    [PAYMENTREQUEST_0_SHIPPINGAMT] => 0.00
    [PAYMENTREQUEST_0_ITEMAMT] => 8
    )

    2017-06-18T22:07:08+00:00 INFO SetExpressCheckout Response: Array
    (
    [TIMESTAMP] => 2017-06-18T21:07:09Z
    [CORRELATIONID] => 8e5363eb7cdf3
    [ACK] => Failure
    [VERSION] => 124.0
    [BUILD] => 35149711
    [L_ERRORCODE0] => 10727
    [L_ERRORCODE1] => 10728
    [L_ERRORCODE2] => 10729
    [L_ERRORCODE3] => 10730
    [L_SHORTMESSAGE0] => Shipping Address1 Empty
    [L_SHORTMESSAGE1] => Shipping Address City Empty
    [L_SHORTMESSAGE2] => Shipping Address State Empty
    [L_SHORTMESSAGE3] => Shipping Address Postal Code Empty
    [L_LONGMESSAGE0] => The field Shipping Address1 is required
    [L_LONGMESSAGE1] => The field Shipping Address City is required
    [L_LONGMESSAGE2] => The field Shipping Address State is required
    [L_LONGMESSAGE3] => The field Shipping Address Postal Code is required
    [L_SEVERITYCODE0] => Error
    [L_SEVERITYCODE1] => Error
    [L_SEVERITYCODE2] => Error
    [L_SEVERITYCODE3] => Error

    Plugin Contributor angelleye

    (@angelleye)

    We have some theories we are testing here. We’ll be sure to keep you posted and try to push another update very soon if we’re able to pin-point the problem.

    One thing, since you mentioned you’re using virtual products, please check to see if you also have “No Shipping Required” checked at the product level.

    Plugin Contributor angelleye

    (@angelleye)

    @kireaki, I need to ask once more. Are you absolutely sure that you are running on our current release branch, and that you cleared out all of your CDN and caching tools after updating to that version?

    Everything we’re seeing here shows it was fixed in that version.

    Hi, ok so I see you tested in admin area, and i got emails again with errors http://prntscr.com/flg0cr so if everything is right and I do have latest version and I did cleared all cache. If everything is fixed why i get those emails and errors every time :/ I will check now for shipping check option in products

    About Shipping products option in woocommerce

    http://prntscr.com/flg2s3

    Plugin Contributor angelleye

    (@angelleye)

    @kireaki,

    We checked on your site and it seems that you’re running our current 1.4.5 plugin, which is where we know this issue still remains. This has already been fixed in the 1.4.6 update that we’re working on now, which is what our release branch is. You are not running our release branch, though, from what we can see.

    That said, when we run test orders using the test product that we setup on your site, as long as we have No Shipping Required enabled on the product then the order goes through just fine. When we disable No Shipping Required then we are able to reproduce the error you’re reporting.

    So please double that for us. First, it would be best to get updated to our release branch for now. Second, No Shipping Required really should be resolving the issue even on the 1.4.5 copy.

    Sorry for all the back and forth, but please try to clarify some of that for us so that we can be sure we have this fixed for sure. Thanks!

    Ok, so I sound already annoying I know, so i’ve downloaded your plugin from link you posted 47 minutes ago i checked 3 times now and all I see
    http://prntscr.com/flgaj5

    So I don’t understand if ou say it’s 1.4.6 version why i install every time 1.4.5

    I deleted plugin again downloaded again cleared all cache clearead cloudflare it says plugin is 1.4.5 version

    You have admin rights so please do it for me…

    `

    47 minutes ago

    @kireaki, I need to ask once more. Are you absolutely sure that you are running on our current release branch, and that you cleared out all of your CDN and caching tools after updating to that version?

    Everything we’re seeing here shows it was fixed in that version.

    • This reply was modified 2 years, 4 months ago by  kireaki.
    Plugin Contributor angelleye

    (@angelleye)

    Sorry for the confusion. I admit we need to handle our “release branch” better with different versioning.

    As it stands right now, 1.4.5 is the current official release. Our “release branch” always consists of the current official release + any issues on the next release that have been closed. I don’t update the version number in the release branch until we officially release that next version because if you were to apply it today and it already said 1.4.6, then when we release the official 1.4.6 (which would have more fixes at that point) you wouldn’t see that update in your WP admin panel.

    In the future we’re going to start using 1.4.5.1, etc. in the release branch to avoid such confusion. I hope that clears it up for now.

    As of now it sounds like you did get updated to the release branch as long as you pulled it from that link I provided earlier. So then if you just make sure you have “No Shipping Required” set in your products you should not run into the error you’ve been reporting.

    Ok, i’ve checked all my products and added on 3 products missing no shipping required so let’s hope it will solve this problem.
    Also naming would be good for future just to avoid this mess 😀 you say update to new version i see same version so I don’k now what is wrong what version I have and what version you have if they all have same number:D

    Anyway tnx for all help I hope all will be ok now.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘PayPal Express Checkout Error Notification’ is closed to new replies.