Support » Plugin: PayPal for WooCommerce » paypal express button not showing on cart page

  • Resolved maccas

    (@maccas)


    I have just noticed this for some reason paypal express button is no longer showing.
    it used to show on the cart page.
    from woocommerce/ checkout options the express checkout is enabled and configured, settings havent changed.
    I am running the latest version, wordpress, woocommerce and angel eye paypal plugin.
    can you help?

Viewing 15 replies - 1 through 15 (of 25 total)
  • claosoftware

    (@claosoftware)

    bump

    same issue

    Plugin Contributor Oliver

    (@angelleyesupport)

    @claosoftware,@maccas, I’m so sorry for the delay getting back to you, We are not getting many reports for this but still, we are checking its compatibility with the latest release 3.2.2 and 3.2.3. Moreover are your themes updated for latest WC release? Can you temporarily switch to Basic WordPress theme ( twenty Seventeen ) and see if you are seeing the Button on cart page?

    dalea

    (@dalea)

    Same issue here. The paypal express button is not showing in the payments area on the checkout page. The only other payment method is stripe.

    The Paypal express button shows at the top of the checkout page

    Checkout Page Display is set to top and in payment area

    Theme is Divi and it is fully up to date

    Plugin Contributor angelleye

    (@angelleye)

    Please double check the Express Checkout settings page for the options about how/where to display the EC button. There are specific options to enable on the product page, cart page, and checkout page. The checkout page setting has multiple options to show at the top, in the regular list of gateways, or both. You need to make sure it’s set to show in the regular list or both if you want it showing up next to Stripe on the checkout page.

    Thread Starter maccas

    (@maccas)

    The express button doesnt show up on the Carts page. I think this did dissapear after updating woocommerce. I already changed the settings with the position of the express checkout button this didnt make a change. I have the latest ideas theme. Tried all sorts of settings to see if it will bring it back. I dont think its settings because it was working fine, it just disseapeared, so its related to the plugin updates not the settings.

    Plugin Contributor Oliver

    (@angelleyesupport)

    But unfortunately, I’m not able to reproduce this issue on my test site, I have tested it with 3 different themes
    1- Enfold
    http://prntscr.com/h8375d
    2- Basic WP theme
    http://prntscr.com/h838mk
    2- StoreFront Theme
    http://prntscr.com/h838dx

    So I’m interested to know the theme all 3 of you are using and are those updated to work with the latest version of WC? Can you guys temporarily switch to Basic WP Theme ( twentySeventeen ) and see if you get the button to show up? Dont forget to clear your browser , CDN and any Plugin cache too.
    Please check those and let me know what you got.
    Thanks!

    dalea

    (@dalea)

    We only want the express checkout button to appear on the checkout page. The button appears at the top of the page but not in the regular payment gateways. The option in the settings page is set to both top and in the payment gateways.

    We are running the divi theme, which is fully up to date, as well as the latest woocommerce version.

    Switching to the Twenty Seventeen theme makes no difference, the top button shows still but it does not show in the payment gateways

    Plugin Contributor Oliver

    (@angelleyesupport)

    @dalea, That is really interesting, Although We are not able to reproduce this, I have just tested with Divi theme as well, but could not see this issue, Can you share your site URL so that I can see it?

    dalea

    (@dalea)

    The site url is pokito.net

    Please let me know what you find

    Thanks

    Plugin Contributor angelleye

    (@angelleye)

    @dalea, Are you absolutely sure you have the option set to display both at the top and the bottom? Can you please double check that? It makes no sense that wouldn’t be working for you in Divi or the Twenty theme.

    If that is truly the case then we’ll need to troubleshoot more directly, so you would need to submit a ticket here please.

    dalea

    (@dalea)

    @angelleye, I can confirm that under the “PayPal Express Checkout” tab within WooCommerce > Checkout the option title Checkout Page Display is set to “Display both at the top and in the general list of gateways on the checkout page”.

    Previously the site was behind a construction page, the site is now live and tested again with Twenty theme, with no change.

    I will submit a ticket now.

    Thanks for the help

    Plugin Contributor Oliver

    (@angelleyesupport)

    That is really interesting, Thanks for submitting the ticket, I will check your ticket and respond you there.
    Thanks!

    dalea

    (@dalea)

    Issue was resolved. If using Aelia Currency switcher, ensure that the requirement payment gateway is enabled in the currency switcher settings for the desired currencies. Woocommerce > Currency switcher > Payment gateways

    Thread Starter maccas

    (@maccas)

    my issue still remains. I have WOOCS – WooCommerce Currency Switcher v.2.2.0, turned the plugin off and on but made no difference. There must be something else preventing the express button being shown on the Cart page.

    Plugin Contributor angelleye

    (@angelleye)

    @dalea, I’m glad you were able to find the issue and get it resolved.

    @maccas, are you able to temporarily disable other plugins and switch to a different theme to see if the button shows up again? Then re-enable each one until it disappears again to find the culprit? There must be something unique there causing this.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘paypal express button not showing on cart page’ is closed to new replies.