Support » Plugin: WooCommerce » Paypal Custom Payment Page Style not working

  • Hey Woocommerce,

    The Paypal Custom Payment Page Style feature is no longer working in Woocommerce, unless we specify that style as the Primary Style.

    But previously, we no need to specify that Style as the Primary Style, and just make sure the style name is the same in Paypal and inside Woocommerce, and it will display our site custom logo!

    What happened? I have several sites under my Paypal Business Account….I do not want my buyers to just see my company name when they checkout!

    I asked Paypal Merchant Technical Support, and they said Woocommerce is not passing the Logo Image URL parameter to Paypal!

Viewing 15 replies - 1 through 15 (of 18 total)
  • Same issue here, the page style is sent in the request parameter page_style=MyPageStyle and the page is set up in the PayPal account, but it doesn’t take effect and the buyer is shown the account’s default page (with the wrong business logo on it).

    I’m experiencing the same issue but I’m wondering if it’s because I’m still running WC 2.5.5. Are you guys running the latest WooCommerce 2.6.11?

    Same issue here- have you found a fix? If so, please share.

    Thread Starter Bliss7

    (@bliss7)

    WooCommerce has so far not shown me any desire to fix the issue. So as long as people do not bang on their doors to get them to fix the issue, it will never gonna be fixed…..

    Has anyone logged an error with them?

    Thread Starter Bliss7

    (@bliss7)

    I did lodge a ticket with Woocommerce (AND Paypal), but Woocommerce asked me for access to my site, and that is AFTER a week of silence. I said to myself forget it.

    Meanwhile, Paypal pointed the finger at Woocommerce…..

    I am just very surprised that not more people bang on their door to demand they address, acknowledge, and fix the issue.

    Or maybe I am just mistaken that Woocommerce users are that many? Maybe not, since Shopify has been going gangbusters the past year….

    *Shrugs*

    • This reply was modified 5 years, 3 months ago by Bliss7.
    • This reply was modified 5 years, 3 months ago by Bliss7.

    Any word on a fix for calling the page style from PayPal yet?

    I too cannot call the intended Page Style using the WooCommerce PayPal settings page. The Page Style is set up correctly in PayPal (the primary page style works fine). However when I call an alternative page style (via it’s name in the Woocommerce PayPal settings) I’m still get the primary style.

    I can see (&page_style=WatchTHAT&paymentaction=sale&bn=WooThemes_Cart&) in the log output (WatchTHAT is the style name) but it’s not working.

    Still the same issue here on our end (we haven’t upgraded to WC 3 though yet). I’ve raised a ticket with woocommerce.com.

    Got word back from WooCommerce support and thought I’d share this here:

    It looks like PayPal may not be supporting the page style options anymore with their new interface. More information on this here: https://github.com/woocommerce/woocommerce/issues/12523

    We added a new image url option, which is a part of the 3.0.0 update: https://github.com/woocommerce/woocommerce/blob/master/CHANGELOG.txt#L77

    You could manually apply this fix if you aren’t ready to update to 3.0 yet but want this resolved: https://github.com/woocommerce/woocommerce/pull/12546/commits/edfc54dff5430d32b8af0c6eb100b459c67c6735

    Thanks Mate, your awesome!

    I saw the new image method but not all my shops will see WC 3.0 so the coding fix is amazing.

    Cheers, if you were a local I’d buy you a beer.

    Happy to help, I merely relayed the message though 🙂

    Hmm, added the changes to WC files on a site with WC 2.6.14 but yet to get PayPal to show anything other than the default page style.

    Log shows the image_url variable is present and correct and sent but no luck 🙁

    Got it sorted, had to remove all page style profiles in PayPal for it to start working (just in case this helps someone).

    Thread Starter Bliss7

    (@bliss7)

    @ dougyboy and everyone concerned

    If you removed all other page style profiles, that means you are only using your Paypal account for one lone website. So having a “Custom Payment Page” is rendered redundant, since you still are forced to use only one website with your Paypal account.

    So if your site was “Wonderful Doorknobs”, that means you can only use that Paypal account with that doorknobs website and have it show “Wonderful Doorknobs” as the logo on the Checkout Page. We are no nearer to resolving the issue, are we?

    Anyway, Paypal seems to have removed the link to Customize the Payment Page, because I am not seeing it as an option anymore under my Paypal Profile. I wonder where you are seeing yours?

    I believe if you want to open 10 ecommerce sites, you need 10 Paypal accounts for EACH site (if you want the checkout page to be unique to each site). Otherwise, suffering a lot of Abandon Carts is the other option.

    That is my only conclusion…..

    🙁

    • This reply was modified 5 years, 1 month ago by Bliss7.

    It does work, you have to use the new method. I have multiple sites and they now all show their individual logo when sent through to PayPal.

    You have to remove all of the old page_style profiles in PayPal (Profile & Settings > Selling Tools > PayPal Buttons ‘Update’ > Manage checkout page styles). Don’t forget to remove any reference to the old page_style variable on your websites.

    Then simply integrate the new method image_url. WC 3.0 already has this set up for you or you can integrate using the links above (I did this effectively for a WC 2.6 site & a PayPal cart plugin site).

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Paypal Custom Payment Page Style not working’ is closed to new replies.