WordPress.org

Forums

WooCommerce - excelling eCommerce
[resolved] PayPal Auto Return/Direct Not Working; PayPal Says WooCommerce Issue (5 posts)

  1. IlanK
    Member
    Posted 9 months ago #

    Hi,

    I have been trying to set up the PayPal Auto Return feature but I can't get it to work. Instead of sending the user to a thank you page, PayPal shows a 404 error on their side (http://pbrd.co/1tWVPq5).

    I have set it up as per the documentation from WooCommerce: http://pbrd.co/1tWW44D

    Upon contacting PayPal, I learned the following:

    "In looking at the information that gets passed to PayPal, your cart is passing a Return URL, however, it is encoding it before it is passed. For example, in my test, I see that it passed

    return:http%3A%2F%2Fgastromio.com%2Fcheckout%2Fthank-you%2F1387%3Fkey%3Dwc_order_53c594aaabcbe%26%23038%3Butm_nooverride%3D1

    This should be sent as

    return:http://gastromio.com/checkout/thank-you/1387?key=wc_order_53c594aaabcbe&utm_nooverride=1

    I tested this using the information, and once I sent the same requests with the encoding removed, the return URL worked. I recommend checking with your cart to see why it is encoding the cancel and the return URLs. Once you correct this, the return and cancel URLs will work like normal."

    Question: How do I fix this encoding issue?

    Thank you!

    Ilan

    https://wordpress.org/plugins/woocommerce/

  2. Claudio Sanches
    Member
    Plugin Author

    Posted 9 months ago #

    Hey please turn off the "Use form submission method" option.
    With the option disabled all works fine.

    The option: http://i.imgur.com/lcjI5Ja.png

    I just fix this in the next release already okay for form submission too.

  3. IlanK
    Member
    Posted 9 months ago #

    Hi, thanks! Yes, sorry, I posted this in the WooCommerce forum and it got resolved there but forgot to update here.

  4. Claudio Sanches
    Member
    Plugin Author

    Posted 9 months ago #

    No problem ;)

  5. arctosmedia
    Member
    Posted 8 months ago #

    Turning off the "Use form submission method." does not work for me. Is there something else I'm missing? I'm having exactly the same problem you were.

Reply

You must log in to post.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic