Support » Plugin: WC Vendors Marketplace » Payments still not working correctly

  • Resolved themememe

    (@themememe)



    Enable instant pay is NOT checked and our payment schedule is set to manual, and yet vendors are been paid instantly. In PayPal we are only receiving our commission, not the whole amount.

Viewing 4 replies - 1 through 4 (of 4 total)
  • There is a pattern to the issue. Only PayPal payments are affected. If a customer has paid via PayPal, the commission is instantly transferred to the vendor. If the payment has been made with Stripe, it remains with a Due status.

    • This reply was modified 5 months, 2 weeks ago by  themememe.
    Plugin Author Jamie

    (@digitalchild)

    Hello,

    I will assume that you have been using Paypal adaptive payments since before they were depreciated.

    Are you running the latest version of WC Vendors? There was an issue in the cron schedules but this was fixed in 2.0.6.

    Unless you’re running my Stripe gateway, stripe does not pay vendors at any time.

    cheers,

    Jamie.

    Yes latest version.

    These are my payment settings: https://imgur.com/a/5cBTOHd

    As I said, even though instant pay is not checked, when customers are paying by PayPal (not Stripe) vendors are paid immediately.

    I don’t have the Stripe gateway for paying vendors, just the WC one that allows customers to pay via Stripe.

    What I’m saying is that vendors are being paid immediately when they shouldn’t be.

    This is what I used to do (prior to 2.x): once a week click ‘Pay Now’ and this would trigger a Mass Payment via PayPal. All I want to do is to continue doing this. This worked fine prior to version 2.x

    • This reply was modified 5 months, 1 week ago by  themememe.
    Plugin Author Jamie

    (@digitalchild)

    Hello,

    Ok I will add an issue to get this investigated and resolved.

    https://github.com/wcvendors/wcvendors/issues/430

    You can follow the issue here.

    cheers

    Jamie.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.