Support » Plugin: WooCommerce Stripe Payment Gateway » Payment Pending – immediately after Sofort redirect

  • Resolved andrija84

    (@andrija84)


    Hello,

    Thank you for this great plugin

    I had a problem:

    1. User select Giropay or Sofort
    2. It has been redirected to external page Sofort or Giropay.
    3. In that time order has been created with status “pending payment”, and the “new order” email has been sent. User did not entered any data, this is all done by simple build in redirect
    4. I want order to be created and email to be sent only on success payments.
    5. Is this normal plugin behaviour or the theme is coded wrong?

    Thank

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Melinda

    (@melindahelt)

    Automattic Happiness Engineer

    Hi there!

    The emails should only be sent after the payment details are entered.

    We’d like to take a deeper look at your status report and setup.

    Please contact us at WooCommerce.com > My Account > Tickets. You may need to create an account before you can access that page.

    Please include a link to this forum thread, so that we can keep track of what’s already been done.

    We will be able to help you further there.

    Hi

    I have managed this in another way by making function witch will only send on payment complete

    This can be closed

    Thanks again

    @andrija84 Hi Buddy,

    Could you please share how you solved this questions? I have the same problem with you…Thanks!

    Hi,

    In the woocommerce settings set only one email for new order, that would be for your internal note. You will have pending payments and then you can then send email to the client as a reminder witch is good

    Then you can make separate functions witch will only send emails on payment success and this mail would be send only to external vendors.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Payment Pending – immediately after Sofort redirect’ is closed to new replies.