Support » Plugin: Stripe For WooCommerce » Payment not always recognised

  • Resolved teuptworkshop

    (@teuptworkshop)


    I’m accepting iDeal payments with this plugin and it works great, but some of the time the order status is stuck on hold, the payment not being recognised. Then when I go into my Stripe account, the funds did came through.

    Is there any reason why some payments would not be recognised, and is there anything to do about it? I already had a customer mail me asking if the order came through, as he did not receive the confirmation mail that normally is triggered when the payment is made.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author mr.clayton

    (@mrclayton)

    Hi @teuptworkshop

    When using local payment methods like Ideal you need to ensure that you have set up webhooks.

    If a customer navigates away from your site before the local payment method can be processed the webhooks act as insurance, guaranteeing that the order status is set appropriately which means emails are triggered etc.

    If you have not done so please navigate to the stripe plug-ins API settings page and there you will see a link to our how to guide which walks you through all the steps required to set up a webhook.

    Kind regards,

    Thanks for the explanation, I had not done that yet! When I tested it and it worked I figured all was good without paying more attention. I’m assuming this solves my issue, thanks! 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Payment not always recognised’ is closed to new replies.